Tutorial :Will iPhone base SDK allow what iphones can run the app?



Question:

I have been developing an iPhone app and now I am trying to build the binary.

I have noticed the base SDK is set to iPhone 4.0. Does this mean only iPhone 4.0 users can run the app?

I can change it to the lowest iPhone device 3.2, but how can I change the target so that I can test on the simulator in OS 3.2?


Solution:1

The Base SDK should be set to the latest iOS version you want to support. To also support older phones, set the “Deployment Target” build setting to the lowest iPhone OS version you want to support. Currently, I don’t believe you can set it to anything less than 3.0 and still get approved by Apple.


Solution:2

That's OS version, not hardware. You can adjust the deployment target and the base SDK to set up handling the differences between 3.x and 4.x APIs. A tutorial on how to do it is here: http://iosdevelopertips.com/xcode/base-sdk-and-iphone-os-deployment-target-developing-apps-with-the-4-x-sdk-deploying-to-3-x-devices.html


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »