Tutorial :ELMAH is not logging



Question:

I've been using ELMAH on my development machine and it works fine. I also deployed it on Win2008 IIS7 and run the LOCALHOST website with force exception and it logs.. However, when i try browsing the website on other machine (using other machine from the network to browse the website) ELMAH is not logging.. I've check the App_Data for xml and none created. I already give Network service persmission on the folders.

So, the problem is when browsing the website in localhost ELMAH logs, when browsing it on other machine it didn't logs.

Below is my web.config file..

<configuration>  <configSections>      <sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">          <sectionGroup name="scripting" type="System.Web.Configuration.ScriptingSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">              <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>              <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35">                  <section name="jsonSerialization" type="System.Web.Configuration.ScriptingJsonSerializationSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="Everywhere"/>                  <section name="profileService" type="System.Web.Configuration.ScriptingProfileServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>                  <section name="authenticationService" type="System.Web.Configuration.ScriptingAuthenticationServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>                  <section name="roleService" type="System.Web.Configuration.ScriptingRoleServiceSection, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" requirePermission="false" allowDefinition="MachineToApplication"/>              </sectionGroup>          </sectionGroup>      </sectionGroup>      <sectionGroup name="elmah">        <section name="security" requirePermission="false" type="Elmah.SecuritySectionHandler, Elmah" />        <section name="errorLog" requirePermission="false" type="Elmah.ErrorLogSectionHandler, Elmah" />        <section name="errorMail" requirePermission="false" type="Elmah.ErrorMailSectionHandler, Elmah" />        <section name="errorFilter" requirePermission="false" type="Elmah.ErrorFilterSectionHandler, Elmah" />      </sectionGroup>  </configSections>  

------------------------------- cut other non related

<httpHandlers>          <remove verb="*" path="*.asmx"/>          <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>          <add verb="*" path="*.mvc" validate="false" type="System.Web.Mvc.MvcHttpHandler, System.Web.Mvc, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add verb="POST,GET,HEAD" name="Elmah" path="elmah.axd" type="Elmah.ErrorLogPageFactory, Elmah" />      </httpHandlers>      <httpModules>          <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add name="UrlRoutingModule" type="System.Web.Routing.UrlRoutingModule, System.Web.Routing, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add name="ErrorLog" type="Elmah.ErrorLogModule, Elmah"/>              <add name="ErrorMail" type="Elmah.ErrorMailModule, Elmah" />              <add name="ErrorFilter" type="Elmah.ErrorFilterModule, Elmah" />      </httpModules>    <system.webServer>      <validation validateIntegratedModeConfiguration="false"/>      <modules runAllManagedModulesForAllRequests="true">          <remove name="ScriptModule"/>          <remove name="UrlRoutingModule"/>          <add name="ScriptModule" preCondition="managedHandler" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add name="UrlRoutingModule" type="System.Web.Routing.UrlRoutingModule, System.Web.Routing, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add name="ErrorLog" type="Elmah.ErrorLogModule, Elmah"/>              <add name="ErrorMail" type="Elmah.ErrorMailModule, Elmah" />              <add name="ErrorFilter" type="Elmah.ErrorFilterModule, Elmah" />      </modules>      <handlers>          <remove name="WebServiceHandlerFactory-Integrated"/>          <remove name="ScriptHandlerFactory"/>          <remove name="ScriptHandlerFactoryAppServices"/>          <remove name="ScriptResource"/>          <remove name="MvcHttpHandler"/>          <remove name="UrlRoutingHandler"/>          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add name="MvcHttpHandler" preCondition="integratedMode" verb="*" path="*.mvc" type="System.Web.Mvc.MvcHttpHandler, System.Web.Mvc, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>          <add name="UrlRoutingHandler" preCondition="integratedMode" verb="*" path="UrlRouting.axd" type="System.Web.HttpForbiddenHandler, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>          <add name="Elmah" verb="POST,GET,HEAD" path="elmah.axd" preCondition="integratedMode" type="Elmah.ErrorLogPageFactory, Elmah" />      </handlers>  </system.webServer>  


Solution:1

When I've had issues with ELMAH in production in the past, it's typically been one of two things:

1) The directory I want to drop the log files in has not been created 2) The ASP.NET worker process does not have write permission to the drop directory

You haven't posted the actual config section here, but I take it from your question that you're doing something like this:

<elmah>      <errorLog type="Elmah.XmlFileErrorLog, Elmah" logPath="~/App_Data" />   </elmah>   

If you're using App_Data, I assume that folder already exists in your deployment directory. If not, you'll need to add it. If it's there, try giving the ASPNET account write privs on that directory, if you haven't already.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »