Tutorial :eclipse (3.5 & 3.6) crashes in ubuntu



Question:

i have a problem with eclipse within ubuntu 10.04 (x86). i installed eclipse by downloading the zip-file, not from the sources. everything worked just fine until i decided to try eclipse 3.6 which i downloaded just as i did with 3.5...

well i saved 3.6 in another directory than 3.5, started it and opened a workspace that i created with 3.5. after working a bit with 3.6 i notices the following problem:

at some times, when i type sth like CLASSNAME. or VARIABLE. (that is when the code-completion dialog pops up), eclipse crashes, when i try to

  • close the code completion window (e.g. by pressing ESC)
  • select sth from the code completion window

or anything else. this problem did NOT occur within 3.5 at ANY time. well - switching back to the old 3.5 did not solve the problem. the crashes now happened also in this version :(

so i tried to:

  • delete the /home/USER/.eclipse dir
  • reinstall java from the sources
  • create a completely new workspace
  • tried the eclipse version from sources (3.5)

nothing helped :(

i'm out of ideas... how do i get rid of this problem?


Solution:1

It looks like bug 308731, which is XulRunner related.

I confirm that the Steffen's solution works for me and it is necessary to set the property "-Dorg.eclipse.swt.browser.XULRunnerPath".

I set:

-vmargs  -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/bin/xulrunner-1.9.2  

in my eclipse.ini

https://bugs.eclipse.org/bugs/attachment.cgi?id=160189
(crash when pressing Enter on content assist selection)


Solution:2

Add -Dorg.eclipse.swt.browser.DefaultType=mozilla at the end of your eclipse.ini file

It works for me :)


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »