Tutorial :Installing JavaHL 1.6 on CentOS



Question:

I'm looking to install the 1.6 version of JavaHL on CentOS, which proves to be more tricky then expected.

Has someone succeed doing so and can point a repo for this?

Thanks in advance.


Solution:1

I resolved that issue on rhel5u5 64 bit, but doing a ckeckout from the latest stable tag and doing a full build of subversion and the javahl binding svn co http://svn.apache.org/repos/asf/subversion/tags/1.6.11 svn-1-6-11

./configure --prefix=/opt/subversion --enable-javahl --with-jdk=/usr/lib/jvm/java-1.6.0-sun.x86_64  make   make install  make javahl  make install-javahl  

You will need to get many dependencies from the repositories though.


Solution:2

On my CentOS 5 machine, the following worked like a charm:

yum install subversion-javahl

It pulled the rpm from the dries repo. If you don't have yum configured to pull from dries: http://dries.ulyssis.org/rpm/clientconfig.html

Remember, as has been said by others here, that JavaHL is pretty version-sensitive - I'm running subclipse 1.6 / subversion 1.6, so I installed JavaHL 1.6. Make sure you're installing the right version.


Solution:3

CollabNet provides an RHEL/CentOS RPM that includes JavaHL.

http://www.open.collab.net/downloads/subversion/redhat.html


Solution:4

To do this for JavaHL 1.7 on centos5.8:

svn co http://svn.apache.org/repos/asf/subversion/tags/1.7.5/ svn-1-7-5  cd svn-1-7-5/  ./get-deps.sh  #<---- not sure if that one's necessary.  . autogen.sh  ./configure --prefix=/opt/subversion --enable-javahl --with-jdk=/usr/lib/jvm/java-1.6.0  make  make install  make javahl  make install-javahl  


Solution:5

on Centos 6.3:

yum install subversion-javahl.x86_64  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »