Tutorial :netbeans subversion authentication failed



Question:

Today i started getting a weird error, i couldnt access any subversion repo from my netbeans app. I keep getting authentication failed.

I am using ubuntu 9.10 and netbeans 6.7.1. My credentials are ok, i can connect, update, commit using RapidSVN.

thanks :)

Later edit

  • i am not behind a proxy
  • didn't updated the working copy,
  • the svn server was not updated
  • the only thing different is that i updated my linux to ubuntu 9.10


Solution:1

i have found the problem, it was caused because the default keyring password was not set, so netbeans could not save the credentials, but for some reason the keyring GUI would not fire to ask for a password.

The solution was to open filezilla that seemed to trigger the keyring GUI and enter a password for the default keyring, after that it all worked


Solution:2

This alternate procedure worked for me on Karmic:

Or, in a terminal, "rm ~/.gnome2/keyrings/login.keyring" without quotes.

After that, run Ubuntu One, it will open the keyring and asked for a new password.


Solution:3

Do you use SvnKit in your netbeans application?

RapidSVN always uses the standard subversion libraries, so there could be a difference between these two.. especially in how they store credentials in the keystores.


Solution:4

Propably you updated your working copy to a newer format via using RapidSVN.
Try to checkout your working copy again.

Subversion has some incompatibilities between working copys from servers <= 1.5 and 1.6. Be carefull. You'll find more information in the release notes of Subversion.

Ok, your clarifications crossed out my answer. Nonetheless, I won't delete it, propably some other users may use this information.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »