Tutorial :Why can I not access VMware Server on port 8333?



Question:

I am using VMware Server 2 and all of a sudden I can't access the management console (homepage).

I am using Internet Explorer and it says page (https://servername:8333/ui/) cannot be displayed. Is there a way to correct this?

How do I check to see if port 8333 is open? How do I open port 8333?

Thanks!


Solution:1

VMware Server 2 on Windows, I suppose?

Happens to me once in a while, too. Restarting the "VMware authentication service" (not at the console right now, can't tell you the exact service name) fixes it.


Solution:2

try http://servername:8222


Solution:3

My setup gives me the same error as yours. I'm not actually sure what is causing it, but if you're looking for a work-around try connecting on port 8222. Basically 8333 is a HTTPS communication port whereas 8222 just works.

You'll also want to double-check that both ports are open in Windows Firewall, depending on which Windows OS you're using. (I'm assuming it's Windows since you mentioned Internet Explorer..)


Solution:4

I had same problem - admin "works" in Firefox, but does not render correctly, and there is no console plugin for Chrome, however - accessing http://myMachine:8222/ui/# instead of https://myMachine:8333/ui/# works. I suspect IE is barfing at the lack of signed certificate.


Solution:5

I had this problem also. All of the tricks I could find, F8 on boot, disabling cert validation etc didnt do the trick. The ports were not listening and going to the hostname or 127.0.0.1/ui/ did not work.

What I did to fix the problem on Windows 7 Professional:

Run the VMware server.exe installation file, the one you used to install the architecture.

Choose REPAIR, click next and let it run all the way through.

Reboot,

It should be working now.


Solution:6

This reply might be a bit on the simple side, but anyway.. Are you sure the VMware Server is running? Because on my Windows box the "VMware Server Web Access" service just fails and stops occasionally for some reason.


Solution:7

If you want to know if the port 8333 is open then use the Open Port Check Tool.

But if you want to know how to open the port then take a look at the PortForward.com site.

Remember that I never used VMware Server, but if you take a look at the configuration, maybe that's configured to another port.


Solution:8

If you are using Windows, open the Services control panel, then restart the VMWare Host Agent service


Solution:9

The settings in the datastores.xml are required to initialize the VMware Host Agent service. When the settings are invalid, the service does not start. This service must be started for the administration web page to function.

To start the service:

  • Log on to the server as an administrator.
  • Browse to the following folder (this can be done by copying the below path into a Start > Run window or the Start menu search bar):

    • Windows Vista, 7, Server 2008 R2: %SYSTEMROOT%\ProgramData\VMware\VMware Server\hostd\
    • Windows XP: %ALLUSERSPROFILE%\Application Data\VMware\VMware Server\hostd\
    • Windows Server 2008: %SYSTEMROOT%\AppData\VMware\VMware Server\hostd\
  • Replace the file datastores.xml with datastores.xml.default. If the file does not exist, remove datastores.xml and restart the VMware Host Agent service. The file should be regenerated automatically.

  • If the problem persists, uninstall and reinstall VMware Server

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »