Tutorial :iPhone OS 3.0



Question:

I am currently working with a device that has iPhone OS 2.2.1. And as You all know that the OS 3.0 update is available for download. I have downloaded the update and also read many comments on it. I have developed all my apps on OS 2.2.1. Just to confirm , if i install 3.0 on my device will the apps be compatible. If not then can I roll back to 2.2.1.If rolling back is possible then how can I roll back?

Thnk You All.


Solution:1

Are your Apps for sale in the App Store? Or are they private apps? Apple won't approve any that aren't 3.0 compatible now, but I'm pretty sure all 2.2.1 apps work on 3.0.

With the iPhone simulator, you can test for different versions. With the device, there is no easy way to roll back to 2.2.1.


Solution:2

To answer your question about downgrading, I did exactly this process yesterday, downgrading my iPod Touch 2G from the 3.0 GM firmware, down to 2.2.1.

First of all, you need to get hold of the 2.2.1 Firmware. There are links list on http://www.blogsdna.com/2264/iphone-firmware-221-and-ipod-touch-firmware-221-released.htm

If you download the zip file and there is a .zip filename suffix, simply remove the '.zip' portion from the filename. Do not unzip the file. The ipsw file uses zip to encapsulate the various files associated with a firmware upgrade.

Next, you need to connect your device to your Mac, and place it in DFU mode. This involves holding down the home and power buttons until the device powers off, and then lifting your finger off the power button, but keeping it on the home button for a few seconds, and then releasing. This is a little tricky, so have a look at the various articles written on the topic. It took me a couple of times to get it right.

Once you've put the device in DFU mode, you can use Xcode's Organizer window to load the 2.2.1 firmware onto the device. Go to the Software Versions menu, and select Other Version.... Then browse to your downloaded 2.2.1 firmware file, and click Open, and then click Restore [device].


Solution:3

Maybe you can downgrade with the pwnage tool.. but I'm not sure.. anyway you can try to downgrade to 2.1 and see what happens..


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »