Ubuntu: Wifi not working in Ubuntu 14.04.3



Question:

Recently got a new laptop Acer Aspire E14 (E5-491G-78F8) and installed Ubuntu 14.04.3 on it. I am not able to get wifi working on it.

Details are here http://paste.ubuntu.com/13736305/

Any help is appreciated. Thanks.

$ ifconfig

root@subu-Aspire-E5-491G:/home/subu/wireless# ifconfig eth0      Link encap:Ethernet  HWaddr f0:76:1c:cb:18:9a              inet addr:192.168.0.198  Bcast:192.168.0.255  Mask:255.255.255.0            inet6 addr: fe80::f276:1cff:fecb:189a/64 Scope:Link            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1            RX packets:258249 errors:0 dropped:0 overruns:0 frame:0            TX packets:136361 errors:0 dropped:0 overruns:0 carrier:0            collisions:0 txqueuelen:1000             RX bytes:319411776 (319.4 MB)  TX bytes:20380324 (20.3 MB)    lo        Link encap:Local Loopback              inet addr:127.0.0.1  Mask:255.0.0.0            inet6 addr: ::1/128 Scope:Host            UP LOOPBACK RUNNING  MTU:65536  Metric:1            RX packets:13401 errors:0 dropped:0 overruns:0 frame:0            TX packets:13401 errors:0 dropped:0 overruns:0 carrier:0            collisions:0 txqueuelen:0             RX bytes:1753814 (1.7 MB)  TX bytes:1753814 (1.7 MB)  


Solution:1

Since the wireless script result indicates you have Ubuntu 14.04.3 LTS

Distributor ID:  Ubuntu  Description:    Ubuntu 14.04.3 LTS  Release:    14.04  Codename:   trusty

This has been recently fixed upstream, follow the instructions to install the backported modules and needed firmware

sudo apt-get install build-essential linux-headers-$(uname -r) git  echo "options ath10k_core skip_otp=y" | sudo tee /etc/modprobe.d/ath10k_core.conf  wget https://www.kernel.org/pub/linux/kernel/projects/backports/2015/11/15/backports-20151115.tar.gz  tar zxvf backports-20151115.tar.gz  cd backports-20151115  make defconfig-wifi  make  sudo make install  git clone https://github.com/kvalo/ath10k-firmware.git  sudo cp -r ath10k-firmware/QCA9377 /lib/firmware/ath10k/  cp /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin_WLAN.TF.1.0-00267-1 /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin

And it should work after a reboot

If you have a kernel update and wireless quits again you will need to

cd backports-20151115  make clean  make defconfig-wifi  make  sudo make install

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »