Ubuntu: Upgraded to Chrome 61.0.3163 via ppa on Ubuntu 16.04 but it won't launch because NSS out of date



Question:

I upgraded to Chrome 61.0.3163 via ppa on Ubuntu 16.04 but it won't launch because NSS out of date. Launching Chrome in terminal gives:

NSS >= 3.26 is required. Please upgrade to the latest NSS, and if you still get this error, contact your distribution maintainer.  

Running

sudo apt-get install libnss3  

gives

libnss3 is already the newest version (2:3.21-1ubuntu4)  

Should I try to get a newer version of libnss that's not in the repository? I downgraded my version of Chrome for now.

Edit:

apt-cache policy libnss3  libnss3:    Installed: 2:3.21-1ubuntu4    Candidate: 2:3.21-1ubuntu4    Version table:   *** 2:3.21-1ubuntu4 500          500 http://us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages          100 /var/lib/dpkg/status    cat /etc/apt/sources.list  # deb cdrom:[Ubuntu 16.04 LTS _Xenial Xerus_ - Release amd64 (20160420.1)]/ xenial main restricted    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to  # newer versions of the distribution.  deb http://us.archive.ubuntu.com/ubuntu/ xenial main restricted  # deb-src http://us.archive.ubuntu.com/ubuntu/ xenial main restricted    ## Major bug fix updates produced after the final release of the  ## distribution.  # deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates main restricted    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu  ## team, and may not be under a free licence. Please satisfy yourself as to  ## your rights to use the software. Also, please note that software in  ## universe WILL NOT receive any review or updates from the Ubuntu security  ## team.  deb http://us.archive.ubuntu.com/ubuntu/ xenial universe  # deb-src http://us.archive.ubuntu.com/ubuntu/ xenial universe  # deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates universe    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu   ## team, and may not be under a free licence. Please satisfy yourself as to   ## your rights to use the software. Also, please note that software in   ## multiverse WILL NOT receive any review or updates from the Ubuntu  ## security team.  deb http://us.archive.ubuntu.com/ubuntu/ xenial multiverse  # deb-src http://us.archive.ubuntu.com/ubuntu/ xenial multiverse  # deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-updates multiverse    ## N.B. software from this repository may not have been tested as  ## extensively as that contained in the main release, although it includes  ## newer versions of some applications which may provide useful features.  ## Also, please note that software in backports WILL NOT receive any review  ## or updates from the Ubuntu security team.  # deb-src http://us.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse    ## Uncomment the following two lines to add software from Canonical's  ## 'partner' repository.  ## This software is not part of Ubuntu, but is offered by Canonical and the  ## respective vendors as a service to Ubuntu users.  deb http://archive.canonical.com/ubuntu xenial partner  deb-src http://archive.canonical.com/ubuntu xenial partner    # deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted  # deb-src http://security.ubuntu.com/ubuntu xenial-security universe  # deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse  


Solution:1

Your computer is not running with the xenial-updates or xenial-security repositories enabled.

Enable the repositories (uncomment the lines for those repositories), and then run sudo apt-get update and sudo apt-get dist-upgrade and upgrade all your packages to the latest package versions.


Solution:2

Your version of libnss3 seems to be broken or missing. Try reinstalling it

sudo apt-get install --reinstall libnss3  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »