Ubuntu: Ubuntu 16.04 LTS - How can I use the integrated Intel ALC268 audio device? Or what is a good work-around?



Question:

Computer has a generic Intel motherboard with integrated audio ports.

Everything works great except the audio.

Output from the green "headphone" port to the amplifier sounds like a powerline hum as if the input cable is just acting like an antenna.


TROUBLESHOOTING AND INFORMATION GATHERING:

Upon startup, via pressing of F2, was able to verify that audio is enabled in the BIOS.

Then after boot into Ubuntu 16.04 LTS and login, with a terminal window open:

This command

dmidecode | more  

shows the Base Motherboard to be Intel DQ35J0

When I type in

aplay -l  

I get this:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC268 Analog [ALC268 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0

This command

lspci -v | grep -A7 -i "audio"  

gives this:

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
Subsystem: Intel Corporation 82801I (ICH9 Family) HD Audio Controller
Flags: bus master, fast devsel, latency 0, IRQ 32
Memory at e0420000 (64-bit, non-prefetchable) [size=16K]
Capabilities:
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02) (prog-if 00 [Normal decode])


CONCLUSION:

Ubuntu can detect the device at the hardware level and the snd_hda-intel kernel driver is installed.


PROBLEM DESCRIPTION:

When I go into sound settings via right-clicking on the speaker, the output section device list is blank.

No audio comes out of the port whether I try Youtube in Chromium or use aplay with a .mp3 file.

Rhythmbox finds the files, and when I click play it turns into a pause symbol. Yet no audio comes out.


Question: How can I use the integrated Intel ALC268 audio device? Or what is the best work-around?


Solution:1

I suggest you to install pavucontrol, it will give you more details to your audio settings. Go to Settings tab and verify what you have. May be audio output is not properly set. Try to switch to another set.


Solution:2

It is obvious that the on-board audio controller is not going to be able to serve its intended purpose. It is possible to get sound out of it, but for whatever reason it is very distorted.

Intel offers only the same hda_snd_intel driver that the system already had installed.

So the first part of the question: How to get it to work? It is a waste of time, so don't even try.


But the SECOND part of the question turned out to be SUPER EASY.
How to work around it.

Turns out that Amazon offers sound cards inside a USB dongle that work just great. If you want them in just a few days they are under $5. But if you are willing to wait a week, they are $1.65 each.

Here is what they look like:

enter image description here

They do not require any drivers, and work with Windows, Linux and even Android (for tablets that have USB ports). I tried it with all three - tablet was a RCA Viking Pro. Totally universal plug and play.

Once it is installed into a USB port here is what the Ubuntu sound options look like:

enter image description here

The Digital Output works fine, and the speakers plug into the green socket.

The best part of this solution is that it will work for any computer or device with a USB port.

Sound quality is excellent. Problem solved.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »