Ubuntu: Problem with scanner Canoscan LiDE 120, image is black, ubuntu 16.04



Question:

The scanner is working correctly under windows and is detected correctly under ubuntu 16.04.

I was expecting this link CanoScan LiDE 120 on Ubuntu 16.04: Scan completely black to solve the problem as my symptoms seem to be exactly the same as given there but it hasn't worked.

For the first command I got this, pressing ENTER to continue where told, I'm not sure what the keyring etc means, did it work?

alex@alex-16:~$ sudo add-apt-repository ppa:rolfbensch/sane-git   Ubuntu SANE packages from SANE daily git snapshots (http://www.sane-project.org/snapshots/).    Unchanged SANE daily git snapshots are ignored!    Please send scanner related questions to the SANE mailing list <email address hidden>.    If you need the last released scanner driver, you can use my other PPA: https://launchpad.net/~rolfbensch/+archive/ubuntu/sane-release.   More info: https://launchpad.net/~rolfbensch/+archive/ubuntu/sane-git  Press [ENTER] to continue or ctrl-c to cancel adding it    gpg: keyring `/tmp/tmpxabubqvw/secring.gpg' created  gpg: keyring `/tmp/tmpxabubqvw/pubring.gpg' created  gpg: requesting key B7CC8701 from hkp server keyserver.ubuntu.com  gpg: /tmp/tmpxabubqvw/trustdb.gpg: trustdb created  gpg: key B7CC8701: public key "Launchpad PPA for Rolf Bensch" imported  gpg: Total number processed: 1  gpg:               imported: 1  (RSA: 1)  OK  alex@alex-16:~$  

After this I entered "sudo apt-get update" as instructed and this seems ok. Because it contains more than 8 links I was told I couldn't post all of it.

alex@alex-16:~$ sudo apt-get update  Hit:1 http://ppa.launchpad.net/atareao/telegram/ubuntu xenial InRelease  Hit:2 http://archive.canonical.com xenial InRelease                                                                                          ......  Hit:10 http://ppa.launchpad.net/rolfbensch/sane-git/ubuntu xenial InRelease                                                                  Hit:11 https://repo.skype.com/deb stable InRelease                                                                                           Hit:12 http://ppa.launchpad.net/videolan/stable-daily/ubuntu xenial InRelease                                                           Hit:13 http://dl.google.com/linux/chrome/deb stable Release  Fetched 306 kB in 0s (347 kB/s)  Reading package lists... Done  alex@alex-16:~$  

After this my symptoms were not changed and I'm not sure what to try next.

Well, anyway, thanks for any help.


Solution:1

That keyring stuff is expected when you add the ppa.

When you did sudo apt-get update, the list of program sources is refreshed, but no actual updates are done.

To actually incorporate the updates from the ppa, you must do sudo apt-get upgrade

Once you do that, as of today, if you do an apt-cache policy libsane and see this in the first line of the results

Installed: 1.0.27+git20171029-xenial0

then you will have indeed installed the latest software from that ppa.

I can't tell if this will actually help your problem, but there is a good chance it will. It helped with our Canon scanner problems.

Note: It is possible that your question should be closed as a duplicate of the one you mention. I'm choosing to interpret it instead as a question about you having difficulty incorporating the solution found in that question's answer.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »