Ubuntu: PPTP VPN stops working after disconnected once



Question:

I am using PPTP VPN connection on Ubuntu 16.04 and it is working fine after fresh boot and when I first establish connection. But if it get disconnected by some reason and I reconnect (it reports it reconnected successfully) it stops working - meaning I can not open any web page anymore, I get timeout for all connections.

I found temporary solution by restarting network manager as mentioned in this answer

sudo systemctl restart network-manager.service  

This behaviour only started recently, like 2 weeks ago (maybe bug in one of the updates?), before I had no problems. VPN connection itself is not problematic since it works without problems on different OSs.

Same problem happens if I suspend and resume.

How can I debug and resolve this issue?


Solution:1

This happens to me as well (except with OpenVPN), and to fix it I used sudo killall dnsmasq. Unfortunately I have to do it every time I disconnect and reconnect to my vpn but its better than nothing!

EDIT: I found a solution. Go to the terminal and type

gksudo gedit /etc/NetworkManager/NetworkManager.conf

And comment out the line dns = dnsmasq

Here is the link for where I found this information https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1633912


Solution:2

I came cross the exactly same problem after upgrading my Ubuntu 16.04.

I also found that the "disconnect VPN" button has disappeared after upgrade and "configure VPN" has become constantly gray.

At first i doubt if there's any issue with the NetworkManager package, thus i tried reinstalling all nm packages, but it didn't work.

Then i doubt if my system is corrupted, I even reinstalled the whole OS (only root folder) with newest stable release 16.04.02, but it neither worked.

I suspect that some update in 16.04.02 caused this problem. Really hope this problem could be solved soon.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »