Ubuntu: The mysqli|mysql extension is missing. Please check your PHP configuration



Question:

#sudo apt-get install php-mysqlnd  Reading package lists... Done  Building dependency tree         Reading state information... Done  Package php-mysqlnd is a virtual package provided by:    php7.1-mysql 7.1.2-4+deb.sury.org~xenial+1    php5.6-mysql 5.6.30-7+deb.sury.org~xenial+1    php7.0-mysql 7.0.16-4+deb.sury.org~xenial+1  You should explicitly select one to install.    E: Package 'php-mysqlnd' has no installation candidate  

Can anyone help me, how i solve this issue ?


Solution:1

Install one of the packages that contain your package. Pick the latest:

Also, when installing a package, make sure your libraries are updated with these commands:

$ sudo apt update  $ sudo apt upgrade  $ sudo apt install php7.0-mysql  

Run these steps to purge and install PHPMyAdmin fresh:

$ sudo apt remove --purge phpmyadmin  $ sudo apt install phpmyadmin  

When prompted to delete the PHPMyAdmin database, confirm to delete. When prompt to create the PHPMyAdmin database, confirm to create.

Update:

This is the results of a version conflict. Remove the pertinent files, especially the PHP packages and reinstall a consistent version.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »