Ubuntu: How to fix “The package might be corrupted or you are not allowed to open the file”



Question:

I am following this Linuxbabe tutorial to install Teamviewer in Ubuntu 16.04. But I get this error all the time.

user@MyDir:~$ sudo gdebi teamviewer*.deb  Reading package lists... Done  Building dependency tree          Reading state information... Done  Failed to open the software package  The package might be corrupted or you are not allowed to open the file.   Check the permissions of the file.  

What's the problem and how can I fix it?


Solution:1

I recommend simply double-clicking on the debian package you downloaded. It should open the "Software" app, which will let you install the package.

However, sometimes that fails silently due to a missing dependency. In that case:

  1. Open a terminal window and go to the download directory, for example

    cd ~/Downloads  
  2. Run:

    sudo dpkg -i teamviewer_12.0.85001_i386.deb  

Or whatever the name of your debian package is. From the terminal, you'll see any errors. If there's a missing dependency, you can usually fix it with:

sudo apt-get install -f  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »