Ubuntu: Errors updating zesty packages - apt update/upgrade



Question:

I am trying to update zesty and facing errors. I tried apt-get update/upgrade and apt update as well. I can see that updates are available though. I tried through update manager GUI but faced an issue.

Ign:9 http://mirror.adminbannok.com/ubuntu zesty InRelease                                         Ign:11 http://mirror.adminbannok.com/ubuntu zesty-updates InRelease  Ign:12 http://mirror.adminbannok.com/ubuntu zesty-backports InRelease  Ign:13 http://mirror.adminbannok.com/ubuntu zesty-security InRelease  Err:14 http://mirror.adminbannok.com/ubuntu zesty Release    404  Not Found  Err:15 http://mirror.adminbannok.com/ubuntu zesty-updates Release    404  Not Found  Err:16 http://mirror.adminbannok.com/ubuntu zesty-backports Release    404  Not Found  Err:17 http://mirror.adminbannok.com/ubuntu zesty-security Release    404  Not Found  Lecture des listes de paquets... Fait  E: The repository 'https://dl.bintray.com/sbt/debian  Release' is no longer signed.  N: Updating from such a repository can't be done securely, and is therefore disabled by default.  N: See apt-secure(8) manpage for repository creation and user configuration details.  E: The repository 'http://mirror.adminbannok.com/ubuntu zesty Release' does no longer have a Release file.  N: Updating from such a repository can't be done securely, and is therefore disabled by default.  N: See apt-secure(8) manpage for repository creation and user configuration details.  E: The repository 'http://mirror.adminbannok.com/ubuntu zesty-updates Release' does no longer have a Release file.  N: Updating from such a repository can't be done securely, and is therefore disabled by default.  N: See apt-secure(8) manpage for repository creation and user configuration details.  E: The repository 'http://mirror.adminbannok.com/ubuntu zesty-backports Release' does no longer have a Release file.  N: Updating from such a repository can't be done securely, and is therefore disabled by default.  N: See apt-secure(8) manpage for repository creation and user configuration details.  E: The repository 'http://mirror.adminbannok.com/ubuntu zesty-security Release' does no longer have a Release file.  N: Updating from such a repository can't be done securely, and is therefore disabled by default.  N: See apt-secure(8) manpage for repository creation and user configuration details.  


Solution:1

As described in release notes. Zesty will be supported for 9 months until January 2018. Therefore you can use old-releases site, to install zesty packages.

You can use following sources list entries:

deb http://old-releases.ubuntu.com/ubuntu/ zesty main restricted universe multiverse  deb http://old-releases.ubuntu.com/ubuntu/ zesty-updates main restricted universe multiverse  deb http://old-releases.ubuntu.com/ubuntu/ zesty-security main restricted universe multiverse    deb http://old-releases.ubuntu.com/ubuntu/ zesty-proposed main restricted universe multiverse  deb http://old-releases.ubuntu.com/ubuntu/ zesty-backports main restricted universe multiverse    # this repo is disabled!  #deb http://archive.canonical.com/ubuntu zesty partner    deb-src http://old-releases.ubuntu.com/ubuntu/ zesty main restricted universe multiverse  deb-src http://old-releases.ubuntu.com/ubuntu/ zesty-updates main restricted universe multiverse  deb-src http://old-releases.ubuntu.com/ubuntu/ zesty-security main restricted universe multiverse  

It can be successfully retrieved by apt without any problems.


Solution:2

I am to faced same problem with my system. What I found is at url http://ppa.launchpad.net/openjdk-r/ppa/ubuntu/dists/

========================================================

[ICO] Name Last modified Size Description [DIR] Parent Directory -
[DIR] devel/ 25-Jul-2017 12:18 -
[DIR] hardy/ 21-Oct-2011 17:54 -
[DIR] lucid/ 28-Oct-2015 15:29 -
[DIR] maverick/ 21-Oct-2011 16:34 -
[DIR] natty/ 08-Jul-2011 18:43 -
[DIR] oneiric/ 20-Oct-2011 00:08 -
[DIR] precise/ 25-Jul-2017 12:18 -
[DIR] quantal/ 04-Sep-2012 15:39 -
[DIR] trusty/ 27-Jul-2017 07:45 -
[DIR] vivid/ 15-Apr-2015 20:46 -
[DIR] wily/ 21-Oct-2015 22:03 -
[DIR] xenial/ 25-Jul-2017 12:18 -

=======================================================

The zesty is missing. ^

I changed my zesty with xenial as below and it worked fine for me :

deb http://ppa.launchpad.net/openjdk-r/ppa/ubuntu xenial main


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »