Ubuntu: Enable Wi-Fi disappeared?



Question:

My wireless card has been working fine until I installed the latest update. Now the enable wireless setting is completely gone from the applet in the top launcher. Enable networking is still there. This is my wireless card info:

After rebooting without hardwire:

ole@MKI:~$ iwconfig  eth0      no wireless extensions.    lo        no wireless extensions.  

With hardwire:

    ole@MKI:~$ iwconfig      veth8804537  no wireless extensions.        eth0      no wireless extensions.        lo        no wireless extensions.        br-d6801a10bc52  no wireless extensions.        vethfa5d674  no wireless extensions.        veth236d2de  no wireless extensions.        docker0   no wireless extensions.            ole@MKI:~$ ifconfig      br-d6801a10bc52 Link encap:Ethernet  HWaddr 02:42:fa:7a:67:d4                  inet addr:203.0.113.254  Bcast:0.0.0.0  Mask:255.255.255.0                inet6 addr: fe80::42:faff:fe7a:67d4/64 Scope:Link                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                RX packets:13 errors:0 dropped:0 overruns:0 frame:0                TX packets:680 errors:0 dropped:0 overruns:0 carrier:0                collisions:0 txqueuelen:0                 RX bytes:11368 (11.3 KB)  TX bytes:117173 (117.1 KB)        docker0   Link encap:Ethernet  HWaddr 02:42:32:a6:65:07                  inet addr:172.17.0.1  Bcast:0.0.0.0  Mask:255.255.0.0                inet6 addr: fe80::42:32ff:fea6:6507/64 Scope:Link                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                RX packets:1956 errors:0 dropped:0 overruns:0 frame:0                TX packets:2351 errors:0 dropped:0 overruns:0 carrier:0                collisions:0 txqueuelen:0                 RX bytes:607490 (607.4 KB)  TX bytes:578053 (578.0 KB)        eth0      Link encap:Ethernet  HWaddr a0:1d:48:c2:a9:81                  inet addr:192.168.1.9  Bcast:192.168.1.255  Mask:255.255.255.0                inet6 addr: fe80::a21d:48ff:fec2:a981/64 Scope:Link                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                RX packets:269630 errors:0 dropped:0 overruns:0 frame:0                TX packets:158993 errors:0 dropped:0 overruns:0 carrier:0                collisions:0 txqueuelen:1000                 RX bytes:294183781 (294.1 MB)  TX bytes:22427423 (22.4 MB)        lo        Link encap:Local Loopback                  inet addr:127.0.0.1  Mask:255.0.0.0                inet6 addr: ::1/128 Scope:Host                UP LOOPBACK RUNNING  MTU:65536  Metric:1                RX packets:9713 errors:0 dropped:0 overruns:0 frame:0                TX packets:9713 errors:0 dropped:0 overruns:0 carrier:0                collisions:0 txqueuelen:0                 RX bytes:836695 (836.6 KB)  TX bytes:836695 (836.6 KB)        veth8804537 Link encap:Ethernet  HWaddr 46:d4:42:f2:3d:5b                  inet6 addr: fe80::44d4:42ff:fef2:3d5b/64 Scope:Link                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                RX packets:1956 errors:0 dropped:0 overruns:0 frame:0                TX packets:2467 errors:0 dropped:0 overruns:0 carrier:0                collisions:0 txqueuelen:0                 RX bytes:634874 (634.8 KB)  TX bytes:591237 (591.2 KB)        veth236d2de Link encap:Ethernet  HWaddr fe:37:ae:f5:26:74                  inet6 addr: fe80::fc37:aeff:fef5:2674/64 Scope:Link                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                RX packets:9 errors:0 dropped:0 overruns:0 frame:0                TX packets:801 errors:0 dropped:0 overruns:0 carrier:0                collisions:0 txqueuelen:0                 RX bytes:11256 (11.2 KB)  TX bytes:131095 (131.0 KB)        vethfa5d674 Link encap:Ethernet  HWaddr e2:05:30:83:0e:36                  inet6 addr: fe80::e005:30ff:fe83:e36/64 Scope:Link                UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1                RX packets:22 errors:0 dropped:0 overruns:0 frame:0                TX packets:815 errors:0 dropped:0 overruns:0 carrier:0                collisions:0 txqueuelen:0                 RX bytes:12641 (12.6 KB)  TX bytes:142736 (142.7 KB)          ole@MKI:~$ iwconfig      veth8804537  no wireless extensions.        eth0      no wireless extensions.        lo        no wireless extensions.        br-d6801a10bc52  no wireless extensions.        vethfa5d674  no wireless extensions.        veth236d2de  no wireless extensions.        docker0   no wireless extensions.  


Solution:1

Based on your test results it appears that the recent 14.04 update introduced problems with detecting wireless hardware. And not just your model PCI wifi hw, apparently.

So your options (all rather painful) seem to be

1) Wait for a fix and use wired ethernet in the meantime. There are several similar problem reports out there so a fix might not be long in coming.

2) Roll back to the previous version of 14.04

3) Upgrade to the current LTS release of 16.04


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »