Ubuntu: “The following packages have unmet dependencies” Error



Question:

I tried to install a package through apt-get but I get this error. I've tried many solutions including ones in askubuntu but none worked and things are just getting worse and I get more <package>: Depends: ...

Please help me. I really don't know what do you. I just installed this new Ubuntu. This error is making me old. Isn't this a bug?

Reading package lists...  Building dependency tree...  Reading state information...  You might want to run 'apt-get -f install' to correct these:  The following packages have unmet dependencies:   account-plugin-facebook : Depends: libaccount-plugin-generic-oauth but it is not going to be installed or                                      ubuntu-system-settings-online-accounts but it is not going to be installed   account-plugin-flickr : Depends: libaccount-plugin-generic-oauth but it is not going to be installed or                                    ubuntu-system-settings-online-accounts ...  

A brief history:

sudo apt-get install ia32-libs  sudo apt-get install lib32ncurses5  sudo apt-get install multiarch-support  sudo apt-get install libc6-i386  sudo apt-get install ia32-libs-gtk  sudo apt-get  install libgtk2.0-0:i386  sudo apt-get install ia32-libs-gtk  sudo apt-get install libgtk2.0-dev  sudo apt-get install ia32-libs  sudo apt-get install lib32z1  sudo apt-get install gcc-multilib  sudo apt-get install ia32-libs-gtk  sudo apt-get install ia32-libs-multiarch  dpkg --add-architecture i386   sudo dpkg --add-architecture i386   apt-get install libc6:i386   sudo apt-get install libc6:i386   sudo apt-get install libc6-i386  sudo apt-get install libgtk2.0-0:i386  sudo apt-get install libpangoxft-1.0-0  sudo apt-get install libpangoxft-1.0-0:i386  sudo apt-get install libpangox-1.0.so.0  sudo apt-get install libpangox-1.0.so.0:i386  sudo apt-get install classicmenu-indicator  sudo apt-get install python  sudo apt install python-pip  sudo pip install tensorflow-gpu  pip install tensorflow  sudo apt-get install python-pip python-dev  sudo apt-get install python-dev # (first time I noticed the unmet error(but probably was getting that from a few commands before this. I see the word Depends 4 times in its result(if i'm not mistaken))  sudo apt-get update  sudo apt-get install python-dev  sudo apt-get install -f  sudo apt autoremove  sudo apt-get install python-dev  sudo apt-get clean  sudo apt-get autoclean  sudo apt-get install python-dev  sudo dpkg --configure -a  sudo apt-get -f install  sudo apt-get install python-dev  sudo apt-get -u dist-upgrade  sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade  sudo apt-get install python-dev  sudo apt install aptitude  sudo aptitude install python-dev  sudo apt-get install python-dev  sudo apt-get install libpython-dev  sudo apt-get install libpython2.7-dev  sudo apt-get install libpython2.7-stdlib  sudo apt-get install libpython2.7  sudo apt-get install libpython2.7-dev  sudo apt-get install ppa-purge  sudo apt-get install python-dev  cat /etc/apt/sources.list  mkdir ppa-purge && cd ppa-purge && wget http://mirror.pnl.gov/ubuntu/pool/universe/p/ppa-purge/ppa-purge_0.2.8+bzr56_all.deb && wget http://mirror.pnl.gov/ubuntu//pool/main/a/aptitude/aptitude_0.6.6-1ubuntu1_i386.deb && sudo dpkg -i ./*.deb  sudo ppa-purge ppa:someppa/ppa    sudo apt-get install python-dev  sudo apt-get -f install  sudo apt-get install python-dev  sudo apt-get clean  sudo apt-get autoclean  sudo dpkg --configure -a  sudo apt-get -f install  sudo apt-get install python-dev # (still getting the unmet error. I see the word Depends 525 times in its result).  


Solution:1

Wow, this was super easy, all I had to do was apt-get remove the dependency and install my target package.

For example...

account-plugin-facebook : Depends: libaccount-plugin-generic-oauth but it is not going to be installed or                                      ubuntu-system-settings-online-accounts but it is not going to be installed  

Simply do this

apt-get remove libaccount-plugin-generic-oauth  apt-get install account-plugin-facebook  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »