Ubuntu: Asus ROG Zephyrus Keyboard Backlight not working [duplicate]



Question:

This question already has an answer here:

I'm having quite the time getting my keyboard backlights to work on my ROG Zephyrus laptop. Some of the F# keys do not respond their dedicated function when holding the Fn key. Specifically the key combinations for adjusting keyboard backlight for my model FN+F3 to dim and FN+F4 to brighten.

Specifically, I have followed the many suggestions that were recommended from this link with no luck. I have edited the grub file as below and after updating grub I've done a reboot.

sudo vim /etc/default/grub  GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="  sudo update-grub  reboot  

I've also tried:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi= acpi_backlight=intel  sudo update-grub  reboot  

I've also defined several different options all at once. I've tried a few different combinations as well.

I'm not for sure which one of these it was but caused my computer to lock up on a reboot with two lines indicating a namespace error.

Another setting basically removed all functionality from the keyboard and I had to re image in order to retain basic keyboard functionality back.Some of these additional options that I'm referring to are in the link above but I'm including them below for completeness.

GRUB_CMDLINE_LINUX="acpi_osi=Linux"  GRUB_CMDLINE_LINUX="acpi_backlight=vendor"  GRUB_CMDLINE_LINUX="acpi_osi=linux acpi_backlight=vendor"  GRUB_CMDLINE_LINUX="acpi_osi_Linux"  

I've installed this "brightness-controller" that was suggested on another site but that doesn't resolve anything.

I'm running the 375.82 Nvidia graphics drivers without any issues.

The person in the link above that was asking the question listed some specs from their system using a certain command lshw -C display.

So I'm going to do the same if it will provide any useful information. For specs related to my computer you can refer to this link

  *-display                    description: VGA compatible controller     product: NVIDIA Corporation     vendor: NVIDIA Corporation     physical id: 0     bus info: pci@0000:01:00.0     version: a1     width: 64 bits     clock: 33MHz     capabilities: pm msi pciexpress vga_controller bus_master cap_list rom     configuration: driver=nouveau latency=0     resources: irq:127 memory:db000000-dbffffff memory:b0000000-bfffffff memory:c0000000-c1ffffff ioport:e000(size=128) memory:c0000-dffff  
Quick update 08/16/17

I emailed the driver support team from Asus and they informed me that they are using the Atk drivers to control the keyboard brightness.

So I did some searching around and came across an article here that mentions to run the following command.

echo 3 > /sys/class/leds/asus\:\:kbd_backlight/brightness;exit  

However, when I run the command I'm denied permission. So I added sudo like so and it still failed... Results

So my first question is why I can't execute this command and if I'm doing something wrong what the correct command would be.

From here I looked at what the contents of that location were:

Image1

I then tried a few different commands hoping for a different outcome but the command I tried still failed even with sudo:

Image2

What am I doing wrong here? Can someone give me some commands to try out on this directory to see if I can change the brightness.


Solution:1

I can confirm the Zephyrus keyword isn't working for 17.04

I had the same problem, and I was able to solve it, but I'm using Gentoo with 4.12-8 vanilla sources.

My solution was adding blacklisting asus-nb-wmi, for that, you need the following text inside /etc/modprobe.d/blacklist.conf file

blacklist asus-nb-wmi  

I hope it works! The problem seems to be related because asus-nb-wmi adds one fake (or wrong detected) keyboard device, and hid_asus also adds other device, so desktops seems to be using the first one which is wrong. blacklisting will avoid the bad one and keep the other correctly.

This solution will add suspend, airplane mode, keyboard lights, screen lights, screen keys and volume. That doesn't fix the numeric keyboard.

Regards


Solution:2

I was facing this issue today. I think it's just a permission issue : sudo is not exactly the same as being root on the entire line. To avoid this, the best is to become truly root :

sudo su  echo 3 > /sys/class/leds/asus\:\:kbd_backlight/brightness  

Note that you can also choose 1 and 2 as values, and bind those commands to keyboard shortcuts.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »