Ubuntu: apt: error while loading shared libraries:



Question:

I am very new to linux. When trying to install any software with apt, i get the error

apt-get: error while loading shared libraries: libapt-pkg.so.4.12: cannot open shared object file: No such file or directory  

apt error

I think the problem is that one of apt dependencies libapt-pkg.so.4.12 doesn't exist.

When i type dpkg -l i can see that i have libapt-pkg5.0:amd64. Is this a newer version of what apt needs?

How can i make apt to use the right package version?

Thanks!


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »