Ubuntu: 16.041 LTS Avantfax Install Failing



Question:

I would like to install hylafax+avantfax on Ubuntu 16.04 X64 Desktop LTS,i found this article https://www.howtoforge.com/build-a-hylafax-server-with-avantfax-on-debian-etch/#comments

It's for Debian but as far as i know it should work on Ubuntu either.

I've tried this article on both Debian 8X and Ubuntu 16.04 but it keeps failing on

apt-get install apache2-mpm-prefork apache2-utils apache2.2-common \  libapache2-mod-php5 libapr1 libaprutil1 libpq4 libsqlite3-0 php5-cli php5-common \  mysql-server imagemagick libtiff4-dev netpbm libnetpbm10-dev libungif-bin \  libungif4-dev sudo postfix php-mail php-mail-mime php-file php-db php5-mysql \   psutils wdiff  

part. Both on Debian and Ubuntu i'm getting below output:

Reading package lists... Done  Building dependency tree  Reading state information... Done  Note, selecting 'giflib-tools' instead of 'libungif-bin'  Package apache2.2-common is not available, but is referred to by another package.  This may mean that the package is missing, has been obsoleted, or  is only available from another source  However the following packages replace it:    apache2:i386 apache2    Package libapache2-mod-php5 is not available, but is referred to by another package.  This may mean that the package is missing, has been obsoleted, or  is only available from another source    Package libtiff4-dev is not available, but is referred to by another package.  This may mean that the package is missing, has been obsoleted, or  is only available from another source  However the following packages replace it:    libtiff5-dev:i386 libtiff5-dev    Package php5-cli is not available, but is referred to by another package.  This may mean that the package is missing, has been obsoleted, or  is only available from another source  However the following packages replace it:    php7.0-cli:i386 php7.0-cli    Package php5-common is not available, but is referred to by another package.  This may mean that the package is missing, has been obsoleted, or  is only available from another source    Package php5-mysql is not available, but is referred to by another package.  This may mean that the package is missing, has been obsoleted, or  is only available from another source    Package apache2-mpm-prefork is not available, but is referred to by another package.  This may mean that the package is missing, has been obsoleted, or  is only available from another source    E: Package 'apache2-mpm-prefork' has no installation candidate  E: Package 'apache2.2-common' has no installation candidate  E: Package 'libapache2-mod-php5' has no installation candidate  E: Unable to locate package libpq4  E: Package 'php5-cli' has no installation candidate  E: Package 'php5-common' has no installation candidate  E: Package 'libtiff4-dev' has no installation candidate  E: Unable to locate package libungif4-dev  E: Unable to locate package php-file  E: Package 'php5-mysql' has no installation candidate  

As far as i understand from output, most of the packages changed,re-named or replaced with some other packages.

As a rookie on linux i have no idea how to solve this problem, could you guys guide me how to fix this problem.


Solution:1

Basically avantfax is not built (nor fixed) for php7 (which is default php for Ubuntu 16.04), thus you will need to compile or install php5 first before proceeding. Refer to this post for the answer (which is for nginx): https://www.howtoforge.com/community/threads/ubuntu-16-04-hylafax-avantfax.76168/#post-359073.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »