Tutorial :Visual Web Developer 2008 Express wanting SQL Server 2005 instead of 2008?



Question:

When I double click on an mdf file on Visual Web Developer 2008 (NerdDinner.mdf) it says:

Connections to SQL Server files (*.mdf) require SQL Server Express 2005 to function properly. Please verify the installation of the component or download from the URL: http://go.microsoft.com/fwlink/?LinkId=49251

The URL of course points to SQL Server Express 2008. I have that one installed and running. Any ideas why am I getting that message?


Solution:1

You probably installed Visual Web Developer 2008 Express with custom settings and skipped the database part.

Visual Web Developer 2008 Express was originally shipped with SQL Server Express 2005. At the time, SQL Server Express 2008 wasn't ready yet.

Don't worry about the error message and just install SQL Server Express 2008.


Solution:2

As far as i know support for SQL Server 2008 was added in Service Pack 1 for Visual Studio.

You can download it here.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »