Tutorial :Visual Studio 2008 SP1 “Package Load Failure” Error



Question:

I recently installed VS08 SP1 so that I could use the Entity Framework. However, upon loading projects with edmx files, I get a "Package Load Failure" error that points at "Microsoft.Data.Entity.Design.Package".

Unfortunately, googling this turn up only problems dealing with installing SP1 over the Entity Framework CTP, which I have never installed.

Here's what I've tried:

  • Uninstalling, reinstalling SP1, and restarting many times.
  • Using the Visual Studio 2008 Service Pack Preparation Tool both before and after installing SP1.
  • Used the "Package Load Analyzer" from the Visual Studio SDK. The tests pass, but following the test the previously mentioned error displays.

Edit: Okay I ran VS with logging on and I see the error

Field not found: 'Microsoft.VisualStudio.Modeling.Shell.CommonModelingCommands.PrintPreview'.  


Solution:1

Hope this link will help you. It's a same kind of scenario.

http://support.microsoft.com/kb/962353

http://www.thedatafarm.com/Blog/2007/09/03/EntityFrameworkToolsPackageLoadFailureWhenOpeningUpEDMXInDesignerFAQsAreComing.aspx


Solution:2

My gut response to Package Load Failures, which doesn't always solve the problem, is to open a VS command prompt and run 'devenv /resetskippkgs' (without quotes). If you're on Vista+, you need to run the prompt elevated.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »