Tutorial :Intellij Cannot determine verions for JDK



Question:

Why do I get the error in intellij:

Cannot determine version for JDK flex_sdk_3. Update JDK configuration.


Solution:1

This problem arises if you have a java classes in your source tree. Remove them and the error should disappear.


Solution:2

When loading a project in IntelliJ IDEA, part of the project file is the name of the JDK that the project uses. If you don't have that JDK installed with that name, then IDEA will complain. We found a need to standardize on JDK names in our group.

To add or edit JDKs (at least in IDEA 7.0.4, which I'm using), go into File/Settings/Project Settings. There's a "JDKs" under Platform Settings there you can add JDK versions, and the "General" under Project Settings lets you pick which JDK to use for your project.


Solution:3

I just ran into the same issue. In my idea workspace, I've got 2 kinds of projects: flex project and java projects. By default all the project use the "General project settings" editable through File>Project Structure menu.

Change the default project sdk to whatever fits you the most and then apply specific settings for the others. In my case as I wanted to run JBoss from intellij I chose the default to be java sdk.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »