Ubuntu: Rolling back to non-HWE stack on Ubuntu 16.04.2



Question:

I recently updated the Ubuntu 16.04.1 version on my laptop to 16.04.2 and later updated the kernel and xorg to the HWE stack using this command

sudo apt-get install --install-recommends xserver-xorg-hwe-16.04  

I have been experiencing heating, unexplained shutdowns, and other issues after this upgrade. Is there a safe way to roll back to 16.04.2 without HWE or should I format and reinstall? I tried this in the terminal but doing that caused ubuntu to freeze at the login screen.

sudo apt-get remove xserver-xorg-hwe-16.04  

Any suggestions please? Thanks in advance!


Solution:1

You need to recover the original xserver-xorg.

sudo apt install xserver-xorg-core    sudo apt install ubuntu-desktop xserver-xorg libgl1-mesa-dri:i386 libgl1-mesa-glx:i386  


Solution:2

Boot in root shell. Examine /var/log//var/log/apt/history.log (or older archives in the directory) to see which packages were removed together with xserver-xorg-hwe-16.04. Install them back.

Then run

sudo apt install --purge xserver-xorg-hwe-16.04- xserver-xorg xserver-xorg-core \  xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-synaptics \  xserver-xorg-input-vmmouse xserver-xorg-input-wacom xserver-xorg-video-all \  xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev \  xserver-xorg-video-intel xserver-xorg-video-nouveau xserver-xorg-video-qxl \  xserver-xorg-video-radeon xserver-xorg-video-vesa xserver-xorg-video-vmware  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »