Ubuntu: How to upgrade slapd to 2.4.40?



Question:

I just found out, that connecting via the LDAP API like this

sudo ldapsearch -Q -LLL -Y EXTERNAL -H ldapi:/// -b cn=config dn  

has a bug on Ubuntu 15.04 vivid/openldap-2.4.31. But fortunately, on that bug report, I can find the message, that

This bug was fixed in the package openldap - 2.4.40+dfsg-1ubuntu1

Now how can I upgrade my openLDAP to that specific version? I already did sudo apt-get update and sudo apt-get upgrade. But my current openLDAP version remains 2.4.31.


Solution:1

Version 2.4.40 is currently only available for the next Ubuntu release Wily and there is no PPA with version 2.4.40.

You can download the source code and apply a patch for Utopic and Vivid.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »