Ubuntu: Can't open synaptic package manager after installing get deb



Question:

I have install getdeb by following command

echo "Downloading GetDeb and PlayDeb" &&  wget http://archive.getdeb.net/install_deb/getdeb-repository_0.1-1~getdeb1_all.deb http://archive.getdeb.net/install_deb/playdeb_0.3-1~getdeb1_all.deb &&    echo "Installing GetDeb" &&  sudo dpkg -i getdeb-repository_0.1-1~getdeb1_all.deb &&    echo "Installing PlayDeb" &&  sudo dpkg -i playdeb_0.3-1~getdeb1_all.deb &&    echo "Deleting Downloads" &&  rm -f getdeb-repository_0.1-1~getdeb1_all.deb &&  rm -f playdeb_0.3-1~getdeb1_all.deb  

now when i open synaptic package manger i get following error and it is not opening

E: The value 'trusty-getdeb' is invalid for APT::Default-Release as such a release is not available in the sources  E: _cache->open() failed, please report.  

what should i do? please help!!


Solution:1

You can fix it using this:

gksudo gedit /root/.synaptic/synaptic.conf  

searched for 'trusty' and replaced it with Your Ubuntu codename.

You can get your ubuntu codename by running command:

lsb_release -sc  

Once you've done then run the command:

sudo apt-get update  

Now synaptic must run again.

Source: https://answers.launchpad.net/ubuntu/+source/synaptic/+question/213406


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »