Ubuntu: Cannot install new version of python 2.7



Question:

I keep getting stuck on one esoteric error after another. I am simply trying to upgrade my existing Python 2.7.6 to 2.7.12. Thats all I want to do!

I am on Ubuntu 14.04 LTS.

I have followed the instructions here, and make it all the way to the sudo checkinstall command.

However after I execute it, I get a huge list of (seemingly) ok stuff, followed by:

Compiling /usr/local/lib/python2.7/xml/parsers/expat.py ...  Listing /usr/local/lib/python2.7/xml/sax ...  Compiling /usr/local/lib/python2.7/xml/sax/__init__.py ...  Compiling /usr/local/lib/python2.7/xml/sax/_exceptions.py ...  Compiling /usr/local/lib/python2.7/xml/sax/expatreader.py ...  Compiling /usr/local/lib/python2.7/xml/sax/handler.py ...  Compiling /usr/local/lib/python2.7/xml/sax/saxutils.py ...  Compiling /usr/local/lib/python2.7/xml/sax/xmlreader.py ...  Compiling /usr/local/lib/python2.7/xmllib.py ...  Compiling /usr/local/lib/python2.7/xmlrpclib.py ...  Compiling /usr/local/lib/python2.7/zipfile.py ...  make: *** [libinstall] Error 1    ****  Installation failed. Aborting package creation.    Restoring overwritten files from backup...OK    Cleaning up...OK    Bye.  

I'm getting really frustrated as I don't think this should be this hard... what am I missing? FWIW, I am working in a pip virtual environment.

Thanks.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »