Ubuntu: What's going wrong with QT Creator and preventing me from launching it?



Question:

I am not able to start QT Creator. When I start it the following error is given.

(qtcreator:8508): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",  (qtcreator:8508): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",  (qtcreator:8508): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",  (qtcreato:8508): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",  Connected to accessibility bus at:  "unix:abstract=/tmp/dbus-Ih3kweFmKu,guid=af07d35df387caee7e8705270000001a"   Registered DEC:  true   Invalid parent:  0xa4f5b78 SharedTools::QtSingleApplication(0xbfee5be0, name = "qtcreator")   Requesting child objects for an interface that is a virtual child itself.   Requesting child objects for an interface that is a virtual child itself.   Requesting child objects for an interface that is a virtual child itself.   Requesting child objects for an interface that is a virtual child itself.   Requesting child objects for an interface that is a virtual child itself.   Requesting child objects for an interface that is a virtual child itself.   Requesting child objects for an interface that is a virtual child itself.   Requesting child objects for an interface that is a virtual child itself.   Requesting child objects for an interface that is a virtual child itself.   Requesting child objects for an interface that is a virtual child itself.   QSpiAdaptor::getChild INVALID CHILD:  QWidget(0xa661398, name = "qt_scrollarea_viewport") 2   ASSERT: "interface->childCount() == children.count()" in file adaptor.cpp, line 200  Aborted  


Solution:1

I've found in Nokia developers forums that it is an issue with the Qt version shipped in Ubuntu. More precisely with the style plugin. Anyway, it seems there is a workaround. You should execute the installer with -style cleanlooks parameter.

./Qt_SDK_Lin64_offline_v1_1_4_en.run -style cleanlooks


Solution:2

There is something wrong with the qt-at-spi package (build with assertions ON?). Removing it solves the problem but may reduce accesibility features in other software.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »