Tutorial :Known incompatibilities between Java 1.4 to Java 5



Question:

A list of potential compatibility problems is provided by Sun : http://java.sun.com/j2se/1.5.0/compatibility.html

Have you encountered other problems when running/testing old-1.4-applications against Java 5 (eg. A specific library no longer working ....) ?


Solution:1

You may discover an alternative list of backward compatibility problems in all versions of JDK including 1.4 and 1.5 at the following web-sites:

  • JDK-Results at Japitools Home Page:

    In an ideal world each JDK version would be perfectly backward compatible with the one before. As the following table shows, in reality this is not the case ...

  • Test results for JDK at Java Upstream Tracker:

    This service is aimed at monitoring and analyzing Java libraries development. It is looking for new releases of various libraries and checking them for backward binary and source compatibility ...

These results were obtained by static analysis tools and can be used together with the official compatibility notes (Incompatibilities in J2SE 5.0 since 1.4.2 from Sun/Oracle).

enter image description here


Solution:2

The Java 1.5.0 deprecated list may be of help.


Solution:3

In general, code that runs under 1.4 should work under 1.5. I don't think any previously deprecated methods were even removed. However, bugs are fixed between releases and you might get some slightly different behavior if your application was written in such a way that depended on the bug (I have encountered this with a Swing application).


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »