Ubuntu: Problem regarding wifi bcm4313



Question:

I've had some troubles with my wifi using Ubuntu. It seems like I can't connect to modems set to a channel above 11. However I can connect to such modem in windows, therefore the problem must be related to ubuntu and to the driver provided for my broadcom bcm4313. I tried switching to the default driver instead of the one coming from the bcmwl-kernel-source which is the one I am running right now as you can see here but the problem persists. Previously I had jumped out of the problem setting the channel on 11, but I'd like to connect also to modems that don't necessarily rely on that channel and below, as I can do in windows. One more detail is that since I switched to brcmsmac I see this message when booting:

Support for cores revisions 0x17 and 0x18 disabled by module param allhwsupport=0.   Try b43.allhwsupport=1.  


Solution:1

Unfortunately this is an issue with all broadcom modules and they seem to be limited to channels 1-11 in 2.4GHz

You might be able to use the patch at https://github.com/respeaker/openwrt/blob/master/package/kernel/mac80211/patches/850-brcmsmac-remove-extra-regulation-restriction.patch to patch the kernel source but it didn't work when I tried it with my BCM4313


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »