Ubuntu: libbluetooth-dev ubuntu 14.04 solve dependency



Question:

install libbluetooth-dev on ubuntu 14.04 error Dependency on libbluetooth3

after i have trouble to install <bluetooth/bluetooth.h> header with

sudo apt-get install libbluetooth-dev  

on ubuntu 14.04 i find a solution.

solution step by step:

  1. install aptitude

    sudo apt-get install aptitude

2.

sudo aptitude install libbluetooth-dev  

3. choose the correct option

this is my output

The following NEW packages will be installed:  libbluetooth-dev{b}   0 packages upgraded, 1 newly installed, 0 to remove and 161 not upgraded.  Need to get 66.4 kB of archives. After unpacking 409 kB will be used.  The following packages have unmet dependencies:   libbluetooth-dev : Depends: libbluetooth3 (= 4.101-0ubuntu13) but 4.101-0ubuntu13.1 is installed.  The following actions will resolve these dependencies:         Keep the following packages at their current version:  1)     libbluetooth-dev [Not Installed]                           Accept this solution? [Y/n/q/?] 1  Action "1": Removing libbluetooth-dev    Package: libbluetooth-dev  State: not installed; will be installed automatically  Version: 4.101-0ubuntu13  Priority: extra  Section: libdevel  Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>  Architecture: amd64  Uncompressed Size: 409 k  Depends: libbluetooth3 (= 4.101-0ubuntu13), libc6-dev | libc-dev  Suggests: pkg-config  Conflicts: bluez-pan, bluez-pan, libbluetooth-dev, libbluetooth-dev, libsdp2-dev             (<= 1.5.2), libsdp2-dev (<= 1.5.2), libbluetooth-dev  Replaces: libsdp2-dev (<= 1.5.2), libsdp2-dev (<= 1.5.2)  Provides: libbluetooth3-dev  Description: Development files for using the BlueZ Linux Bluetooth library   BlueZ is the official Linux Bluetooth protocol stack. It is an Open Source   project distributed under GNU General Public License (GPL).  Homepage: http://www.bluez.org      This action was selected because libbluetooth-dev depends upon libbluetooth3 (=  4.101-0ubuntu13).    Enter "r 1" to prevent this action from appearing in new solutions.  Enter "a 1" to require that new solutions include this action if possible.    Accept this solution? [Y/n/q/?] n  The following actions will resolve these dependencies:         Downgrade the following packages:                                      1)     libbluetooth3 [4.101-0ubuntu13.1 (now) -> 4.101-0ubuntu13 (trusty)]        Accept this solution? [Y/n/q/?] y  The following packages will be DOWNGRADED:    libbluetooth3   The following NEW packages will be installed:    libbluetooth-dev   0 packages upgraded, 1 newly installed, 1 downgraded, 0 to remove and 161 not upgraded.  Need to get 120 kB of archives. After unpacking 409 kB will be used.  Do you want to continue? [Y/n/?] y  Get: 1 http://archive.ubuntu.com/ubuntu/ trusty/main libbluetooth3 amd64 4.101-0ubuntu13 [53.3 kB]  Get: 2 http://archive.ubuntu.com/ubuntu/ trusty/main libbluetooth-dev amd64 4.101-0ubuntu13 [66.4 kB]  Fetched 120 kB in 1s (65.5 kB/s)              dpkg: warning: downgrading libbluetooth3:amd64 from 4.101-0ubuntu13.1 to 4.101-0ubuntu13  (Reading database ... 166981 files and directories currently installed.)  Preparing to unpack .../libbluetooth3_4.101-0ubuntu13_amd64.deb ...  Unpacking libbluetooth3:amd64 (4.101-0ubuntu13) over (4.101-0ubuntu13.1) ...  Selecting previously unselected package libbluetooth-dev.  Preparing to unpack .../libbluetooth-dev_4.101-0ubuntu13_amd64.deb ...  Unpacking libbluetooth-dev (4.101-0ubuntu13) ...  Setting up libbluetooth3:amd64 (4.101-0ubuntu13) ...  Setting up libbluetooth-dev (4.101-0ubuntu13) ...  Processing triggers for libc-bin (2.19-0ubuntu6.9) ...  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »