Ubuntu: Kubuntu 16.04 system crash regularly [closed]



Question:

For a couple of weeks my kubuntu install crashes regularly. Everything completely freezes. No mouse cursor moment, nothing. Most of the time that it happens my machine is running a heavy node task. Than 1 of the 4 core's is at 100%.

I have tried numerus different kernels but this does not seem to have any effect.

$ uname -r 4.11.4-041104-generic

My bios version is: 1.4.17

Here is a system log when it happend: (in this case it happend when playing a youtube video)

Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.078006] general protection fault: 0000 [#1] SMP  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.078041] Modules linked in: asix usbnet mii bnep pci_stub vboxpci(OE) vboxnetadp(OE) vboxnetflt(OE) vboxdrv(OE) snd_hda_codec_hdmi hid_multitouch i2c_designware_platform i2c_designware_core dell_wmi nls_iso8859_1 dell_laptop intel_rapl x86_pkg_temp_thermal intel_powerclamp dell_led dell_smbios dcdbas snd_soc_skl snd_hda_codec_realtek snd_soc_skl_ipc snd_hda_codec_generic snd_soc_sst_ipc snd_soc_sst_dsp snd_hda_ext_core snd_soc_sst_match snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine snd_hda_intel snd_hda_codec snd_hda_core snd_usb_audio coretemp snd_usbmidi_lib kvm_intel snd_hwdep snd_seq_midi snd_seq_midi_event kvm snd_rawmidi irqbypass crct10dif_pclmul crc32_pclmul snd_pcm ghash_clmulni_intel pcbc snd_seq uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core aesni_intel  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.078423]  videodev aes_x86_64 crypto_simd glue_helper cryptd media intel_cstate intel_rapl_perf snd_seq_device snd_timer input_leds snd joydev serio_raw soundcore brcmfmac rtsx_pci_ms memstick brcmutil cfg80211 mei_me shpchp mei idma64 virt_dma processor_thermal_device intel_soc_dts_iosf intel_lpss_pci intel_pch_thermal hci_uart btbcm btqca btintel bluetooth int3403_thermal intel_lpss_acpi intel_lpss intel_hid int340x_thermal_zone int3400_thermal sparse_keymap acpi_thermal_rel mac_hid acpi_pad acpi_als kfifo_buf industrialio parport_pc sunrpc ppdev lp parport autofs4 hid_generic usbhid rtsx_pci_sdmmc i915 i2c_algo_bit drm_kms_helper nvme syscopyarea sysfillrect nvme_core rtsx_pci psmouse sysimgblt ahci fb_sys_fops drm libahci wmi i2c_hid hid pinctrl_sunrisepoint video pinctrl_intel  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.078799] CPU: 2 PID: 1422 Comm: kwin_x11 Tainted: G           OE   4.11.4-041104-generic #201706071003  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.078849] Hardware name: Dell Inc. XPS 13 9350/07TYC2, BIOS 1.4.17 05/10/2017  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.078887] task: ffff8f86ef4dae00 task.stack: ffffb61d41e9c000  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.078948] RIP: 0010:gen8_ppgtt_insert_pte_entries.isra.43+0xc7/0x1a0 [i915]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.078986] RSP: 0000:ffffb61d41e9f9f0 EFLAGS: 00010202  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079012] RAX: 00000000354d0000 RBX: 0000000000000000 RCX: 0000000000000000  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079041] RDX: 0000000000000018 RSI: ffe41dcbd33a0000 RDI: 00000000354d001b  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079071] RBP: ffffb61d41e9fa48 R08: ffe41dcbd33a0590 R09: ffffffffc042e07a  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079105] R10: 0000000000000000 R11: dead000000000100 R12: 00000000000000b3  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079142] R13: ffffb61d41e9fa60 R14: ffe41dcbd33a0000 R15: 00000000000001d8  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079176] FS:  00007eff19455940(0000) GS:ffff8f86fed00000(0000) knlGS:0000000000000000  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079212] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079241] CR2: 00005591209a3938 CR3: 000000026ec1b000 CR4: 00000000003406e0  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079270] Call Trace:  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079310]  gen8_ppgtt_insert_entries+0xad/0x120 [i915]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079354]  ppgtt_bind_vma+0x40/0x50 [i915]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079398]  i915_vma_bind+0xa0/0x170 [i915]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079444]  __i915_vma_do_pin+0x30b/0x3b0 [i915]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079490]  i915_gem_execbuffer_reserve_vma.isra.30+0x14d/0x1b0 [i915]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079545]  i915_gem_execbuffer_reserve.isra.31+0x3c5/0x3f0 [i915]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079601]  i915_gem_do_execbuffer.isra.37+0x4af/0x15b0 [i915]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079637]  ? __switch_to+0x23c/0x520  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079662]  ? __schedule+0x3ce/0x8c0  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079685]  ? schedule+0x36/0x80  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079706]  ? futex_wait_queue_me+0xd3/0x120  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079753]  i915_gem_execbuffer2+0xa1/0x1e0 [i915]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079794]  drm_ioctl+0x218/0x4b0 [drm]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079837]  ? i915_gem_execbuffer+0x310/0x310 [i915]  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079866]  ? do_futex+0x104/0x520  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079888]  do_vfs_ioctl+0xa3/0x600  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079911]  ? __schedule+0x3ce/0x8c0  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079932]  ? SyS_futex+0x83/0x180  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079952]  SyS_ioctl+0x79/0x90  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079970]  entry_SYSCALL_64_fastpath+0x1e/0xad  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.079996] RIP: 0033:0x7eff18f4af07  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.080017] RSP: 002b:00007ffccb25ec38 EFLAGS: 00000246 ORIG_RAX: 0000000000000010  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.080058] RAX: ffffffffffffffda RBX: 0000000001bcf030 RCX: 00007eff18f4af07  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.080094] RDX: 00007ffccb25ec80 RSI: 0000000040406469 RDI: 000000000000000f  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.080131] RBP: 00007eff194245a0 R08: 0000000001d05ce0 R09: 0000000000000000  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.080174] R10: 0000000000000000 R11: 0000000000000246 R12: 00007eff0f4e9b50  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.080212] R13: 0000000002424717 R14: 00007ffccb25f050 R15: 0000000000d83170  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.080250] Code: 8b 45 08 c1 e0 0c 48 03 47 10 48 89 c7 48 83 cf 1b 85 db 74 12 48 89 c7 48 83 c8 13 40 80 cf 83 83 fb 03 48 0f 44 f8 41 83 c4 01 <49> 89 38 41 81 fc 00 02 00 00 74 78 4c 89 ef e8 c5 a0 e2 e2 84   Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.080413] RIP: gen8_ppgtt_insert_pte_entries.isra.43+0xc7/0x1a0 [i915] RSP: ffffb61d41e9f9f0  Jun 20 18:51:46 billy-XPS-13-9350 kernel: [11616.088989] ---[ end trace b0c9a8b8724703bb ]---  

Here is some additional info:

OpenGL vendor string:  Intel Open Source Technology Center  OpenGL renderer string:Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)   OpenGL version string: 3.0 Mesa 12.0.6 OpenGL shading language v: 1.30  Driver:                Intel  GPU class:             Unknown  OpenGL version:        3.0  GLSL version:          1.30  Mesa version:          12.0.6  X server version:      1.18.4  Linux kernel version:  4.11.4  Requires strict binding:yes  GLSL shaders:          yes  Texture NPOT support:  yes  Virtual Machine:       no  

Any ideas?

Kind regards, Billy


Solution:1

It appeared to be a kernel problem. After installing: 4.11.11-041111-generic all was good. Have been running it for 2 months, no more crashes. ;-)

Thx Javier for you help!

regards, Billy


Solution:2

For sure you have a problem with the video driver.

Try the image for ubuntu 14.04 from dell support

If the problem persist in 14.04 maybe hot? Your model is xps 13 9350?

I see that isn't new installation don't load 14.04. maybe when upgrade the driver the system start to freeze.

then try to change propietary driver.

After installing nvidia drivers, many graphical applications won't launch

done?


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »