Ubuntu: Install latest Rsymphony Ubuntu



Question:

One could install Rsymphony by doing:

apt-get install r-cran-rsymphony  

But that is an old version. When trying to install the latest (from within R), one get:

* installing *source* package ‘Rsymphony’ ...  ** package ‘Rsymphony’ successfully unpacked and MD5 sums checked  Cannot find SYMPHONY libraries and headers.  See <https://projects.coin-or.org/SYMPHONY>.  ERROR: configuration failed for package ‘Rsymphony’  

How to install the latest Rsymphony package?


Solution:1

The Rsymphony documentation indicates that it needs SYMPHONY libraries and headers:

NeedsCompilation:     yes   SystemRequirements:   SYMPHONY libraries and headers  

In Ubuntu, these appear to be provided by the coinor-libsymphony-dev package. Installing that, either using your favorite GUI package manager or from the command line using

sudo apt install coinor-libsymphony-dev  

should solve the issue.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »