Ubuntu: How to install Waterfox browser on Ubuntu 12.04? [duplicate]



Question:

This question already has an answer here:

I want to install the 64 bits version of Firefox - Waterfox on Ubuntu 12.04 system. Since the browser is not available in the software center and I was not able to find any examples of installing it I want to know has anyone do this?

Please,provide more installation details since I am Linux user for few weeks only.


Solution:1

Waterfox is not available for Ubuntu(Linux). To install Waterfox on Ubuntu machine you need Wine package installed.

Wine

Wine is a compatibility layer which allows Windows applications to run on Linux by translating Windows system calls into native Linux calls.

Download the Waterfox installer from here and install it using Wine.

or the alternate way is to install Firefox 64 bit. http://www.firefox64bit.com

Download link for Firefox 64bit OS

Installation steps:

cd /tmp  wget 'http://www.firefox64bit.com/firefox.en-US.linux-x86_64.tar.bz2'  

Extract the file to /opt or ~/firefox directory

sudo tar -jxvf firefox.en-US.linux-x86_64.tar.bz2 -C /opt  

or

tar -jxvf firefox.en-US.linux-x86_64.tar.bz2 -C ~/firefox  


Solution:2

Waterfox 32 & 64 IS now available for Linux/Ubuntu at https://www.waterfoxproject.org/downloads .

It is available as a compressed archive. I installed it in Linux Mint 18.1 like this:

I d/l'd it to my home, then I right clicked on it and selected "extract here". After which, I opened a console and typed in "sudo tar -jxvf waterfox-50.1.0.en-US.linux-x86_64.tar.bz2 waterfox/" (without the parentheses) .

I then went to my "run an application" launcher and typed in waterfox. Joi`la, she worky. Then I created a desktop launcher for it and moved it to a panel.

Hopes this help ya'.

I had a file simply named "waterfox".


Solution:3

You can see if the instructions in this answer, which describe how to install from a repository using apt-get, will help you. I know they work for Trusty Tahr (14.04) and above; they may work for Precise Pangolin (12.04), if you are still using that (but why are you still using that?).


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »