Ubuntu: How can I install AMD GPU (pro) drivers for Ubuntu 16.04, 16.10 or 17.04 (desktop)?



Question:

I tried the package in amd's own site which installs driver of version 17.10. But after I install the driver, login screen does not let me continue, asks forever.

I tried:

  • "nomodeset" in grub (permanent and temporary)
  • following the instructions in amd driver page
  • installing with --px option to remove older drivers before installing
  • decreasing/increasing gnome version
  • searching for older drivers (such as 16.50 but couldn't find) instead of 17.10

System:

FX8150, 8GB RAM, RX550 graphics card, R7-240 graphics card, "Ubuntu usb boot" to install those versions alongside windows 10.


Solution:1

The AMD Radeon R7 240 is a first generation (GCN 1.0) "Oland" GPU that is experimentally supported by the open source amdgpu driver.

Prior to using the amdgpu-pro driver, ensure that:

  1. The kernel you're installing has been built with CONFIG_DRM_AMDGPU_SI=Y and/or CONFIG_DRM_AMDGPU_CIK=Y set to enabled in the kernel config. I no longer use AMD GPUs on any Linux hardware in my possession, so I'm unable to confirm for you if this is enabled by default for Ubuntu. And related to the second point,

  2. If you require any AMD DAL/DC enablement in your deployment (needed to support HDMI Audio,etc) on current generation AMD GPUs for a future upgrade, consider building and deploying this kernel instead. It tends to have the latest security fixes applied to it, so you should be good to go.

  3. Ensure that the radeon module is blacklisted prior to installing the package from AMD.

Also, realize that AMDGPU-Pro works on top of the open-source AMDGPU kernel driver. The driver provides OpenGL, OpenCL, Vulkan and VDPAU support, and as such:

(a). Ensure that KMS is enabled. There should be no modeset lines anywhere on the kernel options passed by the grub configuration file. (b). Whatever kernel you decide to build and install, ensure that you've installed the appropriate linux-firmware package as well. Otherwise, you'll run into trouble particularly with the AMD DAL/DC functionality. (c). And finally, the subject of HDMI and DisplayPort Audio with the opensource amdgpu driver, should you ever roll back from the amdgpu-pro binaries: You'll still need the AMD DAL/DC kernel patchwork linked above.

You may also use this reference should you run into any trouble.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »