Ubuntu: Gnome Builder Run Error


Hello community I'm the newbiest Ubuntu user ever. I'm also Computer Science student migrating to this operation system and looking for clean IDE to build my algorithms. I found one called "Builder" but it is not working properly. I faced two errors, first one was saying to install autopoint after that the second one showed up saying it:

autoreconf: Entering directory `.'  autoreconf: running: autopoint --force  autoreconf: running: aclocal --force   configure.ac:102: error: m4_defn: undefined macro: LT_PACKAGE_VERSION  m4/libtool.m4:40: LT_PREREQ is expanded from...  configure.ac:102: the top level  autom4te: /usr/bin/m4 failed with exit status: 1  aclocal: error: echo failed with exit status: 1  autoreconf: aclocal failed with exit status: 1  

Any ideas to solve this error?


In ubuntu 17.04 gnome-builder package has dependency problem for autotools.

To fix this you need to add two packages more: autopoint, libtool-bin.

Execute this in terminal:

sudo apt install autopoint libtool-bin  

In your case, you have installed autopoint already, so just install libtool-bin.

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Next Post »