Ubuntu: Failed to upgrade from 16.10 to 17.04, now APT throws errors



Question:

After a failed upgrade, when I want to upgrade or install any package i have this problem

$ sudo apt-get upgrade  Reading package lists... Done  Building dependency tree         Reading state information... Done  You might want to run 'apt --fix-broken install' to correct these.  The following packages have unmet dependencies:   python3 : PreDepends: python3-minimal (= 3.5.1-4) but 3.5.3-1 is installed   python3-dev : Depends: python3 (= 3.5.3-1) but 3.5.1-4 is installed                 Depends: libpython3-dev (= 3.5.3-1) but 3.5.1-4 is installed  E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »