Ubuntu: Edimax EW-7811Un wifi adapter not working on Ubuntu 14.04 LTS



Question:

I have installed Ubuntu 14.04 LTS 64-Bit and have a Edimax EW-7811Un wifi adapter. I have tired to get it to work but have no luck.

when I run lsusb command I get:

Bus 001 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]  

iwconfig shows that nothing is being read or connected:

eth0      no wireless extensions.  lo        no wireless extensions.  

I have tired numerous forums and tutorials but cant get it to work, dont know what I am doing wrong.

Can someone give a clear step by step method to get this to work?

uname -r: (Kernel Version)

3.16.0-34-generic  


Solution:1

This has been reported to work:

sudo apt-get install linux-headers-generic build-essential dkms  git clone https://github.com/pvaret/rtl8192cu-fixes.git  sudo dkms add ./rtl8192cu-fixes  sudo dkms install 8192cu/1.10  sudo depmod -a  sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/  

Reboot

(Source)


Solution:2

Ubuntu makes newer kernels (and X Windows) available to the LTS releases, called the LTS Enablement Stack. I installed the latest kernel on my 14.04 (Trusty) system, which at the time of writing is the kernel for Xenial (16.04). Newer kernels have newer drivers and firmware.

sudo apt-get install --install-recommends linux-generic-lts-xenial  

Then reboot to upgrade to the Xenial kernel. On my system, the Edimax adapter worked fine afterward.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »