Ubuntu: Device not managed after upgrade to ubuntu 16



Question:

Hi I recently upgraded to ubuntu 16 but I am now getting this:

which I don't understand because I only have two network devices and they are displayed below as working so what are the two unmanaged devices ?

this is the ifconfig, /NetworkManager.conf and /etc/network/interfaces contents

ifconfig output

NetworkManager.conf  [main]  plugins=ifupdown,keyfile,ofono  dns=dnsmasq    [ifupdown]  managed=true  

and

interfaces  auto lo  iface lo inet loopback  


Solution:1

Those interfaces you see that are Not Managed come from the Virtual Network connections that have been setup by VMware Player. Those are not controlled by the network manager that is why they show up as Unmanaged.

I just did a test on my system here, and they were not listed until I installed VMware Player on it. Unfortunately, the keyboard I am using does not have PrntScrn on it so I cannot get a screenshot of my network connections. But I can do the output of nmcli

Before installation:

:~$ nmcli d  DEVICE      TYPE      STATE      CONNECTION           virbr0      bridge    connected  virbr0               em1         ethernet  connected  Wired connection 1   lo          loopback  unmanaged  --                   virbr0-nic  tun       unmanaged  --                   

After installation:

:~$ nmcli d  DEVICE      TYPE      STATE      CONNECTION           virbr0      bridge    connected  virbr0               em1         ethernet  connected  Wired connection 1   vmnet1      ethernet  unmanaged  --                   vmnet8      ethernet  unmanaged  --                   lo          loopback  unmanaged  --                   virbr0-nic  tun       unmanaged  --                       vmnet1    Link encap:Ethernet  HWaddr 00:50:56:c0:00:01              inet addr:172.16.106.1  Bcast:172.16.106.255  Mask:255.255.255.0            inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1            RX packets:0 errors:0 dropped:0 overruns:0 frame:0            TX packets:61 errors:0 dropped:0 overruns:0 carrier:0            collisions:0 txqueuelen:1000             RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)    vmnet8    Link encap:Ethernet  HWaddr 00:50:56:c0:00:08              inet addr:192.168.192.1  Bcast:192.168.192.255  Mask:255.255.255.0            inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link            UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1            RX packets:0 errors:0 dropped:0 overruns:0 frame:0            TX packets:61 errors:0 dropped:0 overruns:0 carrier:0            collisions:0 txqueuelen:1000             RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)  

After removal of VMware Player:

:~$ nmcli d  DEVICE      TYPE      STATE      CONNECTION           virbr0      bridge    connected  virbr0               em1         ethernet  connected  Wired connection 1   lo          loopback  unmanaged  --                   virbr0-nic  tun       unmanaged  --                   

Hope this helps!


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »