Ubuntu: Wi-fi Atheros pci.id 168c:0042, problem while wifi driver installation



Question:

I followed the steps suggested in the following solution: Qualcomm Atheros Device [168c:0042] (rev 30) Wi-Fi driver installation

But the terminal shows the following:/-------------- | Your kernel headers are incomplete/not installed. | Please install kernel headers, including a .config | file or use the KLIB/KLIB_BUILD make variables to | set the kernel to build against, e.g. | make KLIB=/lib/modules/3.1.7/ | to compile/install for the installed kernel 3.1.7 | (that isn't currently running.)

What should I do. PS: I'm a newbie in linux. So kindly keep it as simple as possible.


Solution:1

Please install the headers package. With a working internet connection, open a terminal Ctrl+Alt+t and run:

sudo apt-get install linux-headers-generic  

Then try your compilation again. Post any errors and we will be happy to help.


Solution:2

It looks like you have a wrong kernel installed for 15.10.

If you did an upgrade from 15.04 that could happen, because of a bug.

You can fix it bu running in terminal

sudo apt-get install linux-generic  

This command will install linux-headers-generic and linux-image-generic. These packages will install the latest kernel and headers for Ubuntu 15.10.

Then reboot and try to install the drivers again.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »