Ubuntu: Ubuntu 16.04 - VSync not enabled, screen tearing



Question:

I'm using:

  • GTX950M
  • Integrated Intel Chipset Graphics from i7-6700
  • Ubuntu 16.04

glxgear detects around 16000 fps.

These are my nvidia drivers:

aptitude search nvidia | grep ^i   i   nvidia-361                      - NVIDIA binary driver - version 361.42       i A nvidia-opencl-icd-361           - NVIDIA OpenCL ICD                           i A nvidia-prime                    - Tools to enable NVIDIA's Prime              i A nvidia-settings                 - Tool for configuring the NVIDIA graphics d  

This my nvidia-config:

#  #  # Configuration file for nvidia-settings - the NVIDIA X Server Settings utility  # Generated on Wed Apr 27 20:37:23 2016  #    # ConfigProperties:    RcFileLocale = C  ToolTips = Yes  DisplayStatusBar = Yes  SliderTextEntries = Yes  IncludeDisplayNameInConfigFile = No  ShowQuitDialog = Yes  UpdateRulesOnProfileNameChange = Yes  Timer = PowerMizer_Monitor_(GPU_0),Yes,1000  Timer = Thermal_Monitor_(GPU_0),Yes,1000  Timer = Memory_Used_(GPU_0),Yes,3000    # Attributes:    0/LogAniso=0  0/FSAA=0  0/TextureSharpen=0  0/TextureClamping=1  0/FXAA=0  0/FSAAAppControlled=1  0/LogAnisoAppControlled=1  0/OpenGLImageSettings=1  0/FSAAAppEnhanced=0  

This my glxinfo:

http://paste.ubuntu.com/16093037/

And this my xrandr:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384  eDP-1 connected primary 1920x1080+0+0 344mm x 193mm     1920x1080     60.01*+  59.93       1680x1050     59.95    59.88       1600x1024     60.17       1400x1050     59.98       1280x1024     60.02       1440x900      59.89       1280x960      60.00       1360x768      59.80    59.96       1152x864      60.00       1024x768      60.04    60.00       960x720       60.00       928x696       60.05       896x672       60.01       960x600       60.00       960x540       59.99       800x600       60.00    60.32    56.25       840x525       60.01    59.88       800x512       60.17       700x525       59.98       640x512       60.02       720x450       59.89       640x480       60.00    59.94       680x384       59.80    59.96       576x432       60.06       512x384       60.00       400x300       60.32    56.34       320x240       60.05    DP-1 disconnected  HDMI-1 disconnected  HDMI-2 disconnected  

And Xorg config:

Section "ServerLayout"      Identifier "layout"      Screen 0 "nvidia"      Inactive "intel"  EndSection    Section "Device"      Identifier "intel"      Driver "modesetting"      BusID "PCI:0@0:2:0"      Option "AccelMethod" "None"  EndSection    Section "Screen"      Identifier "intel"      Device "intel"  EndSection    Section "Device"      Identifier "nvidia"      Driver "nvidia"      BusID "PCI:1@0:0:0"      Option "ConstrainCursor" "off"  EndSection    Section "Screen"      Identifier "nvidia"      Device "nvidia"      Option "AllowEmptyInitialConfiguration" "on"      Option "IgnoreDisplayDevices" "CRT"  EndSection  

But I see a lot of tearing from chrome, videos, etc...

Any idea?


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »