Ubuntu: ubuntu 12.04.5 not able to install mysql server



Question:

(I am new to Ubuntu)

I need to install mysql server on Ubuntu 12.04.5 and I am getting follwing error.

mysql-server Dependes hav unmet dependencies:  mysql-server: Depends : mysql-server-5.5 but it in not going to be installed  E: Unable to correct problems, you have held broken packages.  .....  


Solution:1

I don't understand, how you got into that situation, but you could update your cache

sudo apt-get update  

and then try to let apt-get resolve the problem:

sudo apt-get -f install  

The -f flag fixes broken dependencies.


Solution:2

Sometimes the -f option is not going to work for you. If it doesn't work, then you have to install the package giving an exact version. In order to do so, you can use = to set the version the system wants.

For example:

sudo apt-get install apache2=2.2.20-1ubuntu1  sudo apt-get install mysql-server=5.5  


Solution:3

use this option

sudo apt-get -f install  

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »