Ubuntu: Steam won't start on Ubuntu 15.10



Question:

I just switched from Windows 10 to Ubuntu yesterday (although I've used Ubuntu before). I downloaded Steam and it won't start up. Trying to run it in the terminal provides this:

asto@asto-desktop:~$ steam  Running Steam on ubuntu 15.10 64-bit  STEAM_RUNTIME is enabled automatically  Installing breakpad exception handler for appid(steam)/version(1450127196)  Installing breakpad exception handler for appid(steam)/version(1450127196)  Installing breakpad exception handler for appid(steam)/version(1450127196)  Gtk-Message: Failed to load module "unity-gtk-module"  Installing breakpad exception handler for appid(steam)/version(1450127196)  Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element  Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element  Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number  [1220/001312:ERROR:main_delegate.cc(777)] Could not load cef_extensions.pak  [1220/001312:ERROR:browser_main_loop.cc(203)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.  Installing breakpad exception handler for appid(steamwebhelper)/version(20151214111542)  Installing breakpad exception handler for appid(steamwebhelper)/version(1450091742)  [1220/001312:ERROR:main_delegate.cc(777)] Could not load cef_extensions.pak  Installing breakpad exception handler for appid(steamwebhelper)/version(20151214111542)  Installing breakpad exception handler for appid(steamwebhelper)/version(1450127196)  Installing breakpad exception handler for appid(steamwebhelper)/version(1450127196)  Installing breakpad exception handler for appid(steam)/version(1450127196)  Installing breakpad exception handler for appid(steam)/version(1450127196)  Installing breakpad exception handler for appid(steam)/version(1450127196)  Installing breakpad exception handler for appid(steam)/version(1450127196)  Installing breakpad exception handler for appid(steam)/version(1450127196)  Installing breakpad exception handler for appid(steam)/version(1450127196)  Created shared memory when not owner SteamController_Shared_mem  Wireless receiver firmware /home/asto/.local/share/Steam/ubuntu12_32/../controller_base/d0ggle.bin loaded, version 1442256398.  Installing breakpad exception handler for appid(steam)/version(1450127196)  Installing breakpad exception handler for appid(steam)/version(1450127196)  Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element  Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element  Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number  assert_20151220001311_1.dmp[8119]: Uploading dump (out-of-process)  /tmp/dumps/assert_20151220001311_1.dmp  /home/asto/.local/share/Steam/steam.sh: linio 756ª:  8060 Adres-eraro             (nekropsio elŝutita) $STEAM_DEBUGGER "$STEAMROOT/$STEAMEXEPATH" "$@"  [1220/001313:WARNING:content_browser_client.cc(622)] No browser info matching frame process id 3 and routing id 1  Refresh rate: 1  Refresh rate: 1  Refresh rate: 1  Refresh rate: 1  Refresh rate: 1  Refresh rate: 1  Refresh rate: 1  Refresh rate: 1  Refresh rate: 1  Refresh rate: 1  assert_20151220001311_1.dmp[8119]: Finished uploading minidump (out-of-process): success = yes  assert_20151220001311_1.dmp[8119]: response: CrashID=bp-7996fe25-58d7-4dcd-acbc-ed5b42151219  assert_20151220001311_1.dmp[8119]: file ''/tmp/dumps/assert_20151220001311_1.dmp'', upload yes: ''CrashID=bp-7996fe25-58d7-4dcd-acbc-ed5b42151219''  

I have all of the updates from what I can tell, and have looked at about fifty posts on this same sort of issue, but none helped. It might be because my OS is Esperante, but I doubt it.


Solution:1

I had this problem before. It seems like you are missing fonts. You can install the core fonts by following this guide by howtogeek.

Hope that helps,

Zimbinskers


Solution:2

If it isn't a font problem it might be you are missing some gtk dependency's.

Try to install the gtk module by typing

sudo apt-get install unity-gtk2-module   

Hope that helps, Zimbinskers


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »