Ubuntu: How to install OpenGL 4.0 or 4.5 for developing?



Question:

How i can install OpenGL 4.0 or 4.5 from terminal for developing in C++? I search about it but i can't find a source. And i do not have a directory named GL in usr/include.


Solution:1

Mesa is the GL library used. Ubuntu 16.04 includes Mesa 11.2 which supports OpenGL 4.1. Just install the libgl1-mesa-dev and mesa-common-dev packages to install the development files for it.

If you really need 4.5, you will likely need to develop against the propreitary AMD or NVidia drivers, and you will need a card which actually supports 4.5 to run any software you create using that version of the API.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »