Ubuntu: cannot run software updater on 15.10 [duplicate]



Question:

This question already has an answer here:

I started my Ubuntu 15.10 and am unable to open the software updater app. I keep getting the following error

SystemError: E:Malformed line 55 in source list /etc/apt/sources.list (dist parse)  

I tried purging the app and reinstalling, but still get the same error. Any suggestions?


Solution:1

Do the following to recreate your sources.list. Open a terminal () and type:

sudo su  

Then recreate your sources list by copy&paste the following block into the terminal and press return once.

cat > /etc/apt/sources.list << EOF  deb http://archive.ubuntu.com/ubuntu wily main restricted universe multiverse  deb-src http://archive.ubuntu.com/ubuntu wily main restricted universe multiverse  deb http://archive.ubuntu.com/ubuntu wily-updates main restricted universe multiverse  deb-src http://archive.ubuntu.com/ubuntu wily-updates main restricted universe multiverse  deb http://archive.ubuntu.com/ubuntu wily-backports main restricted universe multiverse  deb-src http://archive.ubuntu.com/ubuntu wily-backports main restricted universe multiverse  deb http://archive.ubuntu.com/ubuntu wily-security main restricted universe multiverse  deb-src http://archive.ubuntu.com/ubuntu wily-security main restricted universe multiverse  deb http://archive.canonical.com/ubuntu wily partner  deb-src http://archive.canonical.com/ubuntu wily partner  EOF  

After that simply type exit to return to your normal user mode. All should be performing normally then.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »