Ubuntu: apt-get install openssh-server doesn't work due to unmet dependencies



Question:

I'm new to Ubuntu environment, its been bothering me since a while.

have tried almost everything suggested in the forums but no luck. I don't know if I'm missing something.

OS: Ubuntu 14.04.1 LTS 64bit

~$ sudo apt-get install openssh-server  Reading package lists... Done  Building dependency tree         Reading state information... Done  Some packages could not be installed. This may mean that you have  requested an impossible situation or if you are using the unstable  distribution that some required packages have not yet been created  or been moved out of Incoming.  The following information may help to resolve the situation:  The following packages have unmet dependencies:   openssh-server : Depends: libck-connector0 (>= 0.2.1) but it is not installable                    Recommends: ncurses-term but it is not installable                    Recommends: ssh-import-id but it is not installable  E: Unable to correct problems, you have held broken packages.  


Solution:1

got it !!, I downloaded the libck-connector0 from Ubuntu package repository , installed it using sudo dpkg -i libck-connector0_0.4.5-2ubuntu0.1_amd64.deb and then tried it again. It worked this time.

and check this link How do I resolve unmet dependencies after adding a PPA?, this guy covered all possible scenarios for such errors.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »