Ubuntu: 16.04 upgrade from 15.10 pkgs being removed instead of upgraded



Question:

Trying to upgrade twice now, but failed:

An unresolvable problem occurred while calculating the upgrade.    This can be caused by:  * Upgrading to a pre-release version of  Ubuntu  * Running the current pre-release version of Ubuntu  *  Unofficial software packages not provided by Ubuntu    If none of this applies, then please report this bug using the command  'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.  

In review of the upgrade "apt.log" the upgrade script appears to be removing packages as opposed to upgrading them. i.e.: perl-modules is being removed as opposed to upgrading to perl-modules-5.22.

If I am reading this incorrectly, please advise or put me in the correct direction.

SC

--apt.log (list of broken items)--

Starting pkgProblemResolver with broken count: 29 Starting 2 pkgProblemResolver with broken count: 29 Investigating (0) perl-base [ amd64 ] < 5.20.2-6ubuntu0.2 -> 5.22.1-9 > ( perl ) Broken perl-base:amd64 Breaks on perl-modules [ amd64 ] < 5.20.2-6ubuntu0.2 > ( perl ) (< 5.22.1~)  Considering perl-modules:amd64 -2 as a solution to perl-base:amd64 5475  Added perl-modules:amd64 to the remove list Broken perl-base:amd64 Breaks on perl-modules [ i386 ] < none > ( none ) (< 5.22.1~)  Considering perl-modules:amd64 -2 as a solution to perl-base:amd64 5475  Added perl-modules:amd64 to the remove list  Fixing perl-base:amd64 via remove of perl-modules:amd64  MarkDelete perl-modules [ amd64 ] < 5.20.2-6ubuntu0.2 > ( perl ) FU=0  Fixing perl-base:amd64 via remove of perl-modules:amd64 Investigating (0) findutils [ amd64 ] < 4.4.2-9build1 -> 4.6.0+git+20160126-2 > ( utils ) Broken findutils:amd64 Breaks on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (< 3.4.4-2)  Considering libpython3.4-minimal:amd64 0 as a solution to findutils:amd64 5103  Added libpython3.4-minimal:amd64 to the remove list  Fixing findutils:amd64 via remove of libpython3.4-minimal:amd64  MarkDelete libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) FU=0 Investigating (0) libgnome-desktop-3-12 [ amd64 ] < none -> 3.18.2-1ubuntu1 > ( libs ) Broken libgnome-desktop-3-12:amd64 Breaks on libgnome-desktop-3-10 [ amd64 ] < 3.16.2-2ubuntu2 > ( libs )  Considering libgnome-desktop-3-10:amd64 -3 as a solution to libgnome-desktop-3-12:amd64 53  Added libgnome-desktop-3-10:amd64 to the remove list  Fixing libgnome-desktop-3-12:amd64 via remove of libgnome-desktop-3-10:amd64  MarkDelete libgnome-desktop-3-10 [ amd64 ] < 3.16.2-2ubuntu2 > ( libs ) FU=0 Investigating (0) libmwaw-0.3-3 [ amd64 ] < none -> 0.3.7-1ubuntu2 > ( libs ) Broken libmwaw-0.3-3:amd64 Conflicts on libmwaw-0.3-3v5 [ amd64 ] < 0.3.5-1ubuntu1 > ( libs )  Considering libmwaw-0.3-3v5:amd64 -3 as a solution to libmwaw-0.3-3:amd64 10  Added libmwaw-0.3-3v5:amd64 to the remove list  Fixing libmwaw-0.3-3:amd64 via remove of libmwaw-0.3-3v5:amd64  MarkDelete libmwaw-0.3-3v5 [ amd64 ] < 0.3.5-1ubuntu1 > ( libs ) FU=0 Investigating (0) libodfgen-0.1-1 [ amd64 ] < none -> 0.1.6-1ubuntu2 > ( libs ) Broken libodfgen-0.1-1:amd64 Conflicts on libodfgen-0.1-1v5 [ amd64 ] < 0.1.4-1ubuntu1 > ( libs )  Considering libodfgen-0.1-1v5:amd64 -3 as a solution to libodfgen-0.1-1:amd64 10  Added libodfgen-0.1-1v5:amd64 to the remove list  Fixing libodfgen-0.1-1:amd64 via remove of libodfgen-0.1-1v5:amd64  MarkDelete libodfgen-0.1-1v5 [ amd64 ] < 0.1.4-1ubuntu1 > ( libs ) FU=0 Investigating (0) unity-control-center-faces [ amd64 ] < none -> 15.04.0+16.04.20160413-0ubuntu2 > ( gnome ) Broken unity-control-center-faces:amd64 Conflicts on gnome-control-center-shared-data [ amd64 ] < 1:3.16.3-0ubuntu1 > ( gnome )  Considering gnome-control-center-shared-data:amd64 -3 as a solution to unity-control-center-faces:amd64 9  Added gnome-control-center-shared-data:amd64 to the remove list  Fixing unity-control-center-faces:amd64 via remove of gnome-control-center-shared-data:amd64  MarkDelete gnome-control-center-shared-data [ amd64 ] < 1:3.16.3-0ubuntu1 > ( gnome ) FU=0 Investigating (0) libqca2 [ amd64 ] < none -> 2.1.1-2ubuntu1 > ( universe/libs ) Broken libqca2:amd64 Conflicts on libqca2v5 [ amd64 ] < 2.1.0-0ubuntu10 > ( libs )  Considering libqca2v5:amd64 -3 as a solution to libqca2:amd64 4  Added libqca2v5:amd64 to the remove list  Fixing libqca2:amd64 via remove of libqca2v5:amd64  MarkDelete libqca2v5 [ amd64 ] < 2.1.0-0ubuntu10 > ( libs ) FU=0 Investigating (0) unity-lens-music [ amd64 ] < 6.9.0+15.04.20141219-0ubuntu1 -> 6.9.1+16.04-0ubuntu1 > ( gnome ) Broken unity-lens-music:amd64 Conflicts on unity-scope-musicstores [ amd64 ] < 6.9.0+15.04.20141219-0ubuntu1 > ( gnome )  Considering unity-scope-musicstores:amd64 -3 as a solution to unity-lens-music:amd64 4  Added unity-scope-musicstores:amd64 to the remove list  Fixing unity-lens-music:amd64 via remove of unity-scope-musicstores:amd64  MarkDelete unity-scope-musicstores [ amd64 ] < 6.9.0+15.04.20141219-0ubuntu1 > ( gnome ) FU=0 Investigating (0) libvoikko1 [ amd64 ] < none -> 4.0.1-3ubuntu1 > ( libs ) Broken libvoikko1:amd64 Conflicts on libvoikko1v5 [ amd64 ] < 3.7.1-1ubuntu1 > ( libs )  Considering libvoikko1v5:amd64 -3 as a solution to libvoikko1:amd64 1  Added libvoikko1v5:amd64 to the remove list  Fixing libvoikko1:amd64 via remove of libvoikko1v5:amd64  MarkDelete libvoikko1v5 [ amd64 ] < 3.7.1-1ubuntu1 > ( libs ) FU=0 Investigating (0) libpython3.4-stdlib [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) Broken libpython3.4-stdlib:amd64 Depends on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)  Considering libpython3.4-minimal:amd64 0 as a solution to libpython3.4-stdlib:amd64 1  Added libpython3.4-minimal:amd64 to the remove list  Fixing libpython3.4-stdlib:amd64 via keep of libpython3.4-minimal:amd64  MarkKeep libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) FU=0 Investigating (0) libmetacity-private3a [ amd64 ] < none -> 1:3.18.4-0ubuntu0.1 > ( libs ) Broken libmetacity-private3a:amd64 Breaks on libmetacity-private3 [ amd64 ] < 1:3.17.2-4ubuntu1 > ( libs ) (< 1:3.18)  Considering libmetacity-private3:amd64 -3 as a solution to libmetacity-private3a:amd64 1  Added libmetacity-private3:amd64 to the remove list  Fixing libmetacity-private3a:amd64 via remove of libmetacity-private3:amd64  MarkDelete libmetacity-private3 [ amd64 ] < 1:3.17.2-4ubuntu1 > ( libs ) FU=0 Investigating (0) libjpeg-progs [ amd64 ] < 8c-2ubuntu8 -> 1:9b-1ubuntu1 > ( universe/graphics ) Broken libjpeg-progs:amd64 Conflicts on libjpeg-turbo-progs [ amd64 ] < 1.3.0-0ubuntu2 -> 1.4.2-0ubuntu3 > ( universe/graphics )  Considering libjpeg-turbo-progs:amd64 -1 as a solution to libjpeg-progs:amd64 0  Added libjpeg-turbo-progs:amd64 to the remove list  Conflicts//Breaks against version 1.3.0-0ubuntu2 for libjpeg-turbo-progs but that is not InstVer, ignoring  Fixing libjpeg-progs:amd64 via remove of libjpeg-turbo-progs:amd64  MarkDelete libjpeg-turbo-progs [ amd64 ] < 1.3.0-0ubuntu2 -> 1.4.2-0ubuntu3 > ( universe/graphics ) FU=0 Investigating (0) libcdr-0.1-1 [ amd64 ] < none -> 0.1.2-2ubuntu2 > ( libs ) Broken libcdr-0.1-1:amd64 Conflicts on libcdr-0.1-1v5 [ amd64 ] < 0.1.1-2ubuntu1 > ( libs )  Considering libcdr-0.1-1v5:amd64 -3 as a solution to libcdr-0.1-1:amd64 0  Added libcdr-0.1-1v5:amd64 to the remove list  Fixing libcdr-0.1-1:amd64 via remove of libcdr-0.1-1v5:amd64  MarkDelete libcdr-0.1-1v5 [ amd64 ] < 0.1.1-2ubuntu1 > ( libs ) FU=0 Investigating (0) libcheese7 [ amd64 ] < 3.16.1-1ubuntu2 > ( libs ) Broken libcheese7:amd64 Depends on cheese-common [ amd64 ] < 3.16.1-1ubuntu2 -> 3.18.1-2ubuntu3 > ( gnome ) (= 3.16.1-1ubuntu2)  Considering cheese-common:amd64 11 as a solution to libcheese7:amd64 -1  Removing libcheese7:amd64 rather than change cheese-common:amd64  MarkDelete libcheese7 [ amd64 ] < 3.16.1-1ubuntu2 > ( libs ) FU=0 Investigating (0) tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java ) Broken tzdata-java:amd64 Depends on tzdata [ amd64 ] < 2016d-0ubuntu0.15.10 -> 2016d-0ubuntu0.16.04 > ( libs ) (= 2016d-0ubuntu0.15.10)  Considering tzdata:amd64 37 as a solution to tzdata-java:amd64 -1  Removing tzdata-java:amd64 rather than change tzdata:amd64  MarkDelete tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java ) FU=0 Investigating (0) libwpd-0.10-10v5 [ amd64 ] < 0.10.0-2ubuntu4 > ( libs ) Broken libwpd-0.10-10v5:amd64 Depends on libwpd-0.10-10 [ amd64 ] < 0.10.0-2ubuntu4 -> 0.10.1-1ubuntu1 > ( libs ) (= 0.10.0-2ubuntu4)  Considering libwpd-0.10-10:amd64 7 as a solution to libwpd-0.10-10v5:amd64 -2  Removing libwpd-0.10-10v5:amd64 rather than change libwpd-0.10-10:amd64  MarkDelete libwpd-0.10-10v5 [ amd64 ] < 0.10.0-2ubuntu4 > ( libs ) FU=0 Investigating (0) xserver-xorg-input-mouse [ amd64 ] < 1:1.9.1-1 > ( x11 ) Broken xserver-xorg-input-mouse:amd64 Depends on xorg-input-abi-21 [ amd64 ] < none > ( none )  Considering xserver-xorg-core:amd64 41 as a solution to xserver-xorg-input-mouse:amd64 -2  Removing xserver-xorg-input-mouse:amd64 rather than change xorg-input-abi-21:amd64  MarkDelete xserver-xorg-input-mouse [ amd64 ] < 1:1.9.1-1 > ( x11 ) FU=0 Investigating (0) libperl5.20 [ amd64 ] < 5.20.2-6ubuntu0.2 > ( libs ) Broken libperl5.20:amd64 Depends on perl-base [ amd64 ] < 5.20.2-6ubuntu0.2 -> 5.22.1-9 > ( perl ) (= 5.20.2-6ubuntu0.2)  Considering perl-base:amd64 5475 as a solution to libperl5.20:amd64 -2  Removing libperl5.20:amd64 rather than change perl-base:amd64  MarkDelete libperl5.20 [ amd64 ] < 5.20.2-6ubuntu0.2 > ( libs ) FU=0 Investigating (0) libcheese-gtk23 [ amd64 ] < 3.16.1-1ubuntu2 > ( libs ) Broken libcheese-gtk23:amd64 Depends on libcheese7 [ amd64 ] < 3.16.1-1ubuntu2 > ( libs ) (>= 3.4.0)  Considering libcheese7:amd64 -1 as a solution to libcheese-gtk23:amd64 -2  Removing libcheese-gtk23:amd64 rather than change libcheese7:amd64  MarkDelete libcheese-gtk23 [ amd64 ] < 3.16.1-1ubuntu2 > ( libs ) FU=0 Investigating (0) postgresql-9.4-pgpool2 [ amd64 ] < 3.3.4-1 > ( database ) Broken postgresql-9.4-pgpool2:amd64 Depends on libpgpool0 [ amd64 ] < 3.3.4-1 -> 3.4.3-1 > ( universe/database ) (= 3.3.4-1)  Considering libpgpool0:amd64 1 as a solution to postgresql-9.4-pgpool2:amd64 -2  Removing postgresql-9.4-pgpool2:amd64 rather than change libpgpool0:amd64  MarkDelete postgresql-9.4-pgpool2 [ amd64 ] < 3.3.4-1 > ( database ) FU=0 Investigating (0) libhunspell-1.3-0v5 [ amd64 ] < 1.3.3-3ubuntu3 > ( libs ) Broken libhunspell-1.3-0v5:amd64 Depends on libhunspell-1.3-0 [ amd64 ] < 1.3.3-3ubuntu3 -> 1.3.3-4ubuntu1 > ( libs ) (= 1.3.3-3ubuntu3)  Considering libhunspell-1.3-0:amd64 35 as a solution to libhunspell-1.3-0v5:amd64 -2  Removing libhunspell-1.3-0v5:amd64 rather than change libhunspell-1.3-0:amd64  MarkDelete libhunspell-1.3-0v5 [ amd64 ] < 1.3.3-3ubuntu3 > ( libs ) FU=0 Investigating (0) checkbox-ng-service [ amd64 ] < 0.20.1-1 > ( utils ) Broken checkbox-ng-service:amd64 Depends on checkbox-ng [ amd64 ] < 0.20.1-1 -> 0.23-2 > ( utils ) (= 0.20.1-1)  Considering checkbox-ng:amd64 0 as a solution to checkbox-ng-service:amd64 -2  Removing checkbox-ng-service:amd64 rather than change checkbox-ng:amd64  MarkDelete checkbox-ng-service [ amd64 ] < 0.20.1-1 > ( utils ) FU=0 Investigating (1) findutils [ amd64 ] < 4.4.2-9build1 -> 4.6.0+git+20160126-2 > ( utils ) Broken findutils:amd64 Breaks on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (< 3.4.4-2)  Considering libpython3.4-minimal:amd64 0 as a solution to findutils:amd64 5103  Added libpython3.4-minimal:amd64 to the remove list  Fixing findutils:amd64 via remove of libpython3.4-minimal:amd64  MarkDelete libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) FU=0 Investigating (1) openjdk-7-jre-headless [ amd64 ] < 7u101-2.6.6-0ubuntu0.15.10.1 > ( java ) Broken openjdk-7-jre-headless:amd64 Depends on tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java )  Considering tzdata-java:amd64 -1 as a solution to openjdk-7-jre-headless:amd64 2  Added tzdata-java:amd64 to the remove list  Fixing openjdk-7-jre-headless:amd64 via keep of tzdata-java:amd64  MarkKeep tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java ) FU=0 Investigating (1) libpython3.4-stdlib [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) Broken libpython3.4-stdlib:amd64 Depends on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)  Considering libpython3.4-minimal:amd64 0 as a solution to libpython3.4-stdlib:amd64 1  Added libpython3.4-minimal:amd64 to the remove list  Fixing libpython3.4-stdlib:amd64 via keep of libpython3.4-minimal:amd64  MarkKeep libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) FU=0 Investigating (1) tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java ) Broken tzdata-java:amd64 Depends on tzdata [ amd64 ] < 2016d-0ubuntu0.15.10 -> 2016d-0ubuntu0.16.04 > ( libs ) (= 2016d-0ubuntu0.15.10)  Considering tzdata:amd64 37 as a solution to tzdata-java:amd64 -1  Removing tzdata-java:amd64 rather than change tzdata:amd64  MarkDelete tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java ) FU=0 Investigating (2) findutils [ amd64 ] < 4.4.2-9build1 -> 4.6.0+git+20160126-2 > ( utils ) Broken findutils:amd64 Breaks on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (< 3.4.4-2)  Considering libpython3.4-minimal:amd64 0 as a solution to findutils:amd64 5103  Added libpython3.4-minimal:amd64 to the remove list  Fixing findutils:amd64 via remove of libpython3.4-minimal:amd64  MarkDelete libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) FU=0 Investigating (2) openjdk-7-jre-headless [ amd64 ] < 7u101-2.6.6-0ubuntu0.15.10.1 > ( java ) Broken openjdk-7-jre-headless:amd64 Depends on tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java )  Considering tzdata-java:amd64 -1 as a solution to openjdk-7-jre-headless:amd64 2  Added tzdata-java:amd64 to the remove list  Fixing openjdk-7-jre-headless:amd64 via keep of tzdata-java:amd64  MarkKeep tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java ) FU=0 Investigating (2) libpython3.4-stdlib [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) Broken libpython3.4-stdlib:amd64 Depends on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)  Considering libpython3.4-minimal:amd64 5103 as a solution to libpython3.4-stdlib:amd64 1  Removing libpython3.4-stdlib:amd64 rather than change libpython3.4-minimal:amd64  MarkDelete libpython3.4-stdlib [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) FU=0 Investigating (2) python3.4 [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) Broken python3.4:amd64 Depends on libpython3.4-stdlib [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)  Considering libpython3.4-stdlib:amd64 5103 as a solution to python3.4:amd64 -1  Removing python3.4:amd64 rather than change libpython3.4-stdlib:amd64  MarkDelete python3.4 [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) FU=0 Investigating (2) python3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) Broken python3.4-minimal:amd64 Depends on libpython3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)  Considering libpython3.4-minimal:amd64 5103 as a solution to python3.4-minimal:amd64 -1  Removing python3.4-minimal:amd64 rather than change libpython3.4-minimal:amd64  MarkDelete python3.4-minimal [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) FU=0 Investigating (2) tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java ) Broken tzdata-java:amd64 Depends on tzdata [ amd64 ] < 2016d-0ubuntu0.15.10 -> 2016d-0ubuntu0.16.04 > ( libs ) (= 2016d-0ubuntu0.15.10)  Considering tzdata:amd64 37 as a solution to tzdata-java:amd64 2  Removing tzdata-java:amd64 rather than change tzdata:amd64  MarkDelete tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java ) FU=0 Investigating (2) libpython3.4 [ amd64 ] < 3.4.3-9ubuntu1 > ( libs ) Broken libpython3.4:amd64 Depends on libpython3.4-stdlib [ amd64 ] < 3.4.3-9ubuntu1 > ( python ) (= 3.4.3-9ubuntu1)  Considering libpython3.4-stdlib:amd64 5103 as a solution to libpython3.4:amd64 -2  Removing libpython3.4:amd64 rather than change libpython3.4-stdlib:amd64  MarkDelete libpython3.4 [ amd64 ] < 3.4.3-9ubuntu1 > ( libs ) FU=0 Investigating (3) openjdk-7-jre-headless [ amd64 ] < 7u101-2.6.6-0ubuntu0.15.10.1 > ( java ) Broken openjdk-7-jre-headless:amd64 Depends on tzdata-java [ amd64 ] < 2016d-0ubuntu0.15.10 > ( java )  Considering tzdata-java:amd64 37 as a solution to openjdk-7-jre-headless:amd64 2  Removing openjdk-7-jre-headless:amd64 rather than change tzdata-java:amd64  MarkDelete openjdk-7-jre-headless [ amd64 ] < 7u101-2.6.6-0ubuntu0.15.10.1 > ( java ) FU=0 Investigating (3) openjdk-7-jre [ amd64 ] < 7u101-2.6.6-0ubuntu0.15.10.1 > ( java ) Broken openjdk-7-jre:amd64 Depends on openjdk-7-jre-headless [ amd64 ] < 7u101-2.6.6-0ubuntu0.15.10.1 > ( java ) (= 7u101-2.6.6-0ubuntu0.15.10.1)  Considering openjdk-7-jre-headless:amd64 37 as a solution to openjdk-7-jre:amd64 -1  Removing openjdk-7-jre:amd64 rather than change openjdk-7-jre-headless:amd64  MarkDelete openjdk-7-jre [ amd64 ] < 7u101-2.6.6-0ubuntu0.15.10.1 > ( java ) FU=0 Done  MarkInstall ubuntu-desktop [ amd64 ] < 1.341 -> 1.361 > ( metapackages ) FU=1  ignore old unsatisfied important dependency on gnome-screensaver:amd64   

Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »