Ubuntu: 16.04 Cannot install anything from Ubuntu Software center [duplicate]



Question:

This question already has an answer here:

Whenever I double click a deb file, it'd be opened in software center. However, when I click "install" button, it'd change to "installing" for a second but then turn back to "install" and nothing happens. It also says "This software comes from a 3rd party and may contain non-free components" at the bottom. I have enabled all the options in Software & Updates and also tried reinstalling software center but nothing helped.


Solution:1

If you want to install programs via .deb files, I suggest to use Gdebi.

It's a lightweight application that is better at installing .deb packages, and is quicker as well. If there are dependencies, it notifies that as well.

In the terminal, type:

sudo apt install gdebi  

You can right click on .deb file and select to open it with Gdebi.

If you like Gdeb, you can make it default to have it open all the .deb files in future.

Read this: http://itsfoss.com/gdebi-default-ubuntu-software-center/


Solution:2

If you need to install software that is not in the repositories, and the Software Center is not working, there is an alternative but it requires the terminal. You must first navigate to the folder where you downloaded the debian package, which is usually in the 'Downloads' folder.

You can open the terminal from that folder by right-clicking and pressing "Open Terminal", or you can navigate to it via the Terminal by:

cd /path/to/folder  

After that you just run this command:

sudo dpkg -i nameofpackage.deb  


Solution:3

If you need to install a software you have two options

  1. using Software Center
  2. using terminal

If you are facing some problem with first method you can go for second method.

  1. Add PPA using following command

    sudo add-apt-repository ppa:<ppa_name>  

    If the above command does not work, try following command

    sudo -E add-apt-repository ppa:<ppa_name>  
  2. Then write following command:

    sudo apt-get update  

    then

    sudo apt-get install <software-name>  


Solution:4

This is not specifically a bug in ubuntu its an APT thing . Its just very unfortunate timing for the 16.04 release that the SHA1 has is being retired. SHA1 is used by the APT system extensively to checksum packages , its being deprecated in favour of SHA256 or SHA512 which is safer.

If you notice a package is not working then please contact the repo maintainer and ask them to update their SHA implementation.

Debians writeup of effected repos and how to update https://wiki.debian.org/Teams/Apt/Sha1Removal

How and why the apt system secures its packages and repositories https://wiki.debian.org/SecureApt

As suggested by others the work around is to manually download the file and verify it yourself before installing with a non repository aware tool like dpkg or gdebi.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »