Ubuntu: Why I can't install TomCat 8 on this Ubuntu 15.04 system? (I obtain an error when I perform chmod statment)



Question:

I am not yet a Linux guy and I am finding some difficulties trying to install TomCat 8 on an Ubuntu 15.04 system that I have to use as development environment.

So I am following this tutorial (I don't know if it is a good tutorial...): http://tutorialforlinux.com/2015/04/21/how-to-install-apache-tomcat-8-on-ubuntu-15-04-vivid-32-64bit-gnulinux-easy-visual-guide/

So I have downloaded the apache-tomcat-8.0.23.tar.gz file from TomCat website and I have extract it.

Now as shown in the tutorial I try to perform this statmet:

andrea@andrea-virtual-machine:~/Scaricati$ sudo chmod -R root:root /apache-tomcat*  

but I obtain this error message:

chmod: modo non valido: "root:root"  

that in english should be sometning like chmod mode not allowed (or something like this).

What could be the problem? How can I correctly install TomCat 8 on my Ubuntu 15.04 system? What exactly does the previous statment?

Tnx


Solution:1

chmod will change the permissions, while chown will change the owner and group of a file. In this case you're erroneously using chmod where you should be using chown.

This is an error in the tutorial you're following, you didn't really do anything wrong but the instructions were mistaken. I suggest you find a book on basic Unix commands so you can learn them, and then you'll be able to catch these basic mistakes on your own.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »