Ubuntu: What's up with python3.4 in the last updates to 14.04



Question:

Something strange happened to python3.4 in the last update cycle. It now appears in Synaptic Package Manager under "installed - local or obsolete" along with all its dependencies.

Why is this? I thought having things appear as 'local or obsolete' was less desirable.

apt-cache policy python3.4 gives me:

python3.4:    Installed: 3.4.3-1ubuntu1~14.04.1    Candidate: 3.4.3-1ubuntu1~14.04.1    Version table:   *** 3.4.3-1ubuntu1~14.04.1 0          100 /var/lib/dpkg/status       3.4.0-2ubuntu1.1 0          500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages          500 http://us.archive.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages       3.4.0-2ubuntu1 0          500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages  

which kind of looks like I downloaded and installed a standalone package, but I certainly did not.

**edit - trusty-proposed is not, and has never been, enabled on the affected PCs.

**edit 2 ** here is my apt log. Looks like the updates were pushed out on September 26. I put asterisks at the key line. You can see that this 3.4.3-1ubuntu1~14.04.1 came in through the normal update channel.

>     Start-Date: 2015-09-26  16:12:06  >     Commandline: aptdaemon role='role-commit-packages' sender=':1.97'  >     Install: blt:amd64 (2.4z-7ubuntu2)  >     Upgrade: python3-problem-report:amd64 (2.14.1-0ubuntu3.13, 2.14.1-0ubuntu3.15), libsystemd-login0:amd64 (204-5ubuntu20.13, 204-5ubuntu20.14), xul-ext-webaccounts:amd64 (0.5-0ubuntu2,  > 0.5-0ubuntu2.14.04.1), systemd-services:amd64 (204-5ubuntu20.13, 204-5ubuntu20.14), libgail18:amd64 (2.24.23-0ubuntu1.2,  > 2.24.23-0ubuntu1.3), firefox-locale-en:amd64 (40.0.3+build1-0ubuntu0.14.04.1, 41.0+build3-0ubuntu0.14.04.1),  > **python3.4:amd64 (3.4.0-2ubuntu1.1, 3.4.3-1ubuntu1~14.04.1)**,  > google-chrome-stable:amd64 (45.0.2454.93-1, 45.0.2454.101-1),  > xul-ext-ubufox:amd64 (3.1-0ubuntu0.14.04.1, 3.2-0ubuntu0.14.04.1),  > firefox:amd64 (40.0.3+build1-0ubuntu0.14.04.1,  > 41.0+build3-0ubuntu0.14.04.1), python3.4-minimal:amd64 (3.4.0-2ubuntu1.1, 3.4.3-1ubuntu1~14.04.1), libsystemd-daemon0:amd64  > (204-5ubuntu20.13, 204-5ubuntu20.14), libgudev-1.0-0:amd64  > (204-5ubuntu20.13, 204-5ubuntu20.14),  > chromium-codecs-ffmpeg-extra:amd64  > (44.0.2403.89-0ubuntu0.14.04.1.1095,  > 45.0.2454.85-0ubuntu0.14.04.1.1097), libpython3.4-stdlib:amd64 (3.4.0-2ubuntu1.1, 3.4.3-1ubuntu1~14.04.1), libpam-systemd:amd64  > (204-5ubuntu20.13, 204-5ubuntu20.14), libufe-xidgetter0:amd64  > (3.0.0+14.04.20140416-0ubuntu1,  > 3.0.0+14.04.20140416-0ubuntu1.14.04.1), gtk2-engines-pixbuf:amd64 (2.24.23-0ubuntu1.2, 2.24.23-0ubuntu1.3), flashplugin-installer:amd64  > (11.2.202.508ubuntu0.14.04.1, 11.2.202.521ubuntu0.14.04.1),  > libgtk2.0-bin:amd64 (2.24.23-0ubuntu1.2, 2.24.23-0ubuntu1.3),  > libgtk2.0-common:amd64 (2.24.23-0ubuntu1.2, 2.24.23-0ubuntu1.3),  > libpython3.4:amd64 (3.4.0-2ubuntu1.1, 3.4.3-1ubuntu1~14.04.1),  > udev:amd64 (204-5ubuntu20.13, 204-5ubuntu20.14),  > libpython3.4-minimal:amd64 (3.4.0-2ubuntu1.1, 3.4.3-1ubuntu1~14.04.1),  > gir1.2-gudev-1.0:amd64 (204-5ubuntu20.13, 204-5ubuntu20.14),  > libudev1:amd64 (204-5ubuntu20.13, 204-5ubuntu20.14), libudev1:i386  > (204-5ubuntu20.13, 204-5ubuntu20.14), binutils:amd64 (2.24-5ubuntu13,  > 2.24-5ubuntu14), lshw:amd64 (02.16-2ubuntu1.2, 02.16-2ubuntu1.3), libgtk2.0-0:amd64 (2.24.23-0ubuntu1.2, 2.24.23-0ubuntu1.3),  > libsystemd-journal0:amd64 (204-5ubuntu20.13, 204-5ubuntu20.14),  > xul-ext-websites-integration:amd64 (2.3.6+13.10.20130920.1-0ubuntu1.1,  > 2.3.6+13.10.20130920.1-0ubuntu1.2), apport-gtk:amd64 (2.14.1-0ubuntu3.13, 2.14.1-0ubuntu3.15), apport:amd64  > (2.14.1-0ubuntu3.13, 2.14.1-0ubuntu3.15),  > webaccounts-extension-common:amd64 (0.5-0ubuntu2,  > 0.5-0ubuntu2.14.04.1), python3-gdbm:amd64 (3.4.0-0ubuntu1, 3.4.3-1~14.04.2), python3-apport:amd64 (2.14.1-0ubuntu3.13, 2.14.1-0ubuntu3.15), idle-python3.4:amd64 (3.4.0-2ubuntu1.1, 3.4.3-1ubuntu1~14.04.1), irqbalance:amd64 (1.0.6-2ubuntu0.14.04.3, 1.0.6-2ubuntu0.14.04.4), xul-ext-unity:amd64 (3.0.0+14.04.20140416-0ubuntu1,  > 3.0.0+14.04.20140416-0ubuntu1.14.04.1), libgail-common:amd64 (2.24.23-0ubuntu1.2, 2.24.23-0ubuntu1.3), python3-tk:amd64  > (3.4.0-0ubuntu1, 3.4.3-1~14.04.2)  >     End-Date: 2015-09-26  16:14:34  


Solution:1

Your installed version is obsolete which means it or a later version isn't available from your current repositories.

Normally I would blame trusty-proposed. If you had that enabled, upgraded python3.4 and then disabled it, it would display exactly per your question.

However, it seems trusty-updates recently had python3.4 version 3.4.3 SRUd into it. This is a post-release feature upgrade. They're pretty rare and usually only follow long testing periods in the -proposed repo.

However the SRU update was recently pulled. It was found to break other things and there's been another regression report here on Ask Ubuntu, so they pulled it back to the last trusty-updates version while they work on fixing the SRU.

This should trickle through the update system when it's done. If everything is working for you, I'd just ignore it.

If it's really bothering you, you could enable trusty-proposed but this might cause more harm than good. Or you could look at downgrading . I haven't found a good way to do this yet.


Note:If u also have question or solution just comment us below or mail us on toontricks1994@gmail.com
Previous
Next Post »